Microsoft Excel

Herbers Excel/VBA-Archiv

Vergleich() unterscheidet Zahlen und Text!? | Herbers Excel-Forum


Betrifft: Vergleich() unterscheidet Zahlen und Text!? von: Reinhard
Geschrieben am: 13.01.2012 19:37:59

Hallo Wissende,

wie in der nachfolgenden Beispieltabelle ersichtlich unterscheidet Vergleich() zwischen Zahlen und Text.
In der Hilfe lese ICH das nicht heraus :-(

1) Kann mir bitte jmd. erklären welcher Logik da Vergleich()/Excel folgt?

2) Angenommen ich will für eine Formel in Zeile 3 in z.B. Zelle X3, da A3 ja leer ist ermitteln welche die nächste gefüllte Zelle in a ist. Das kriege ich heraus mit
=VERGLEICH("*";A3:A11;0)
aus der erhaltenen "3" kann ich dann ja leicht errechnen daß A5 die gesuchte Zelle ist.
Wie aber mache ich das wenn die Spaltendaten nicht wie in A vorliegen sondern wie in B,C,D?

Tabellenblatt: C:\DOKUME~1\ich2\LOKALE~1\Temp\[Mappe1.xls]!Tabelle3
  │ A │ B │ C │ D │  E  │
--┼---┼---┼---┼---┼-----┼
1 │ a │ a │ 1 │   │   1 │
--┼---┼---┼---┼---┼-----┼
2 │   │   │   │   │ #NV │
--┼---┼---┼---┼---┼-----┼
3 │   │   │   │   │ #NV │
--┼---┼---┼---┼---┼-----┼
4 │   │   │   │   │   4 │
--┼---┼---┼---┼---┼-----┼
5 │ a │ 2 │ 2 │ 2 │ #NV │
--┼---┼---┼---┼---┼-----┼
6 │ 3 │ 3 │ 3 │ 3 │     │
--┼---┼---┼---┼---┼-----┼
7 │ 4 │ 4 │ 4 │ 4 │     │
--┴---┴---┴---┴---┴-----┴
Benutzte Formeln:
E1: =VERGLEICH("*";A1:A10;0)
E2: =VERGLEICH("*";C1:C10;0)
E3: =VERGLEICH("*";D1:D10;0)
E4: =VERGLEICH("*";A2:A11;0)
E5: =VERGLEICH("*";B2:B11;0)

A1:E7
haben das Zahlenformat: Standard


Gruß
Reinhard

  

Betrifft: Txt/Z-Vgl: Das liegt daran, ... von: Luc:-?
Geschrieben am: 13.01.2012 20:27:50

…Reinhard,
dass Xl, weil du einen Text-Platzhalter verwendest, davon ausgeht, dass du nur nach Text suchen willst, was doch eigentl recht clever von den xlPgmierern gedacht war, oder?! ;-)
Willst du so auch Zahlen finden, musst du halt alles erst in Text umwandeln, was dann auch eine Matrixfml nötig macht, etwa so:
{=VERGLEICH("*";WENN(ISTLEER(A3:A11);0;TEXT(A3:A11;"0"));0)}
Gruß+schöWE, Luc :-?


  

Betrifft: Alternativ wäre in solchen Fällen allerdings ... von: Luc:-?
Geschrieben am: 13.01.2012 20:41:01

…WFs Fml oder {=VERGLEICH(FALSCH;ISTLEER(A3:A11);0)} zu bevorzugen, Reinhard.
Welche, ist dann eigentl nur noch Geschmacks- bzw Verständnissache.
Luc :-?


  

Betrifft: Danke Luc ^ Walter von: Reinhard
Geschrieben am: 17.01.2012 09:31:39

Hallöchen,

es ging leider irgendwie unter mich hier zurückzumelden, sorry :-(

Daß Platzhalter (Jokerzeichen) , zumindest in diesem Fall, rein auf Text beschränkt sind war mir nicht klar.
Ich sah zwar schon beim Testen daß da zwischen Zahlen und Buchstaben ein Unterschied ist,
deshalb auch der Aufbau der Beispieltabelle, aber egal.
Jetzt weiß ich wie ich ggfs. auch die "erste" Zahelnzelle ermitteln kann.

Gruß
Reinhard


  

Betrifft: {=VERGLEICH(WAHR;(A3:A11<>"");0)} von: WF
Geschrieben am: 13.01.2012 20:28:15

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter (statt Enter allein); - das erzeugt sie.

WF


Beiträge aus den Excel-Beispielen zum Thema "Vergleich() unterscheidet Zahlen und Text!?"