Microsoft Excel

Herbers Excel/VBA-Archiv

istnv(vergleich(... mit zusätzl. Textvergleichkrit | Herbers Excel-Forum


Betrifft: istnv(vergleich(... mit zusätzl. Textvergleichkrit von: HHorst
Geschrieben am: 19.11.2009 10:57:18

Halo nette Leute vom Forum,

ich habe eine wunderbare Formel hier gefunden, aber mit der weiteren Modifizierung habe ich Probleme:

"=WENN(ISTNV(VERGLEICH(ZEILE(M1);$BI:$BI;0));"";INDIREKT("v"&VERGLEICH(ZEILE(M1);$BI:$BI;0)))"
als weiteres Kriterium wollte ich mit isttext die Vorbedingung erweitern und auch mit weiterem Verweis als "und" bzw. "&" bzw. "oder"- komme ich nicht weiter. Hat jemand einen Tipp, was ich wie nehmen muss, um die Quellspalte "H" (Textinhalt) zu berücksichtigen? In den Spalten CB:SL sollen also nur "Wärme" bzw. "Strom" (da beide im Vorfeld auf kWh umgerechnet) und in CN:CX nur die Werte für "Wasser" bzw. "Abwasser" (cbm-Basis) ausgegeben werden. Sverweis mit Bezug auf eine anderes Tabellenblatt mit diesen 4 Begriffen hat mir schließlich auch nur wieder #NV oder anderen Fehler ausgegeben. Wer kann hier helfen?
Danke + Gruß, HHorst

Beispieldatei :
https://www.herber.de/bbs/user/66047.zip
hier sind die Formeln in den Rosaspalten

  

Betrifft: AW: istnv(vergleich(... mit zusätzl. Textvergleichkrit von: Jens
Geschrieben am: 19.11.2009 18:21:45

Hallo

"=WENN(UND(ISTNV(VERGLEICH(ZEILE(M1);$BI:$BI;0));ISTTEXT.......);"";INDIREKT("v"&VERGLEICH(ZEILE(M1);$BI:$BI;0)))"

Gruß Jens


  

Betrifft: AW: istnv(vergleich(... mit zusätzl. Textvergleich von: HHorst
Geschrieben am: 19.11.2009 22:27:25

Hallo Jens,

danke - aber leider genau das funktioniert bei mir nicht:

"=WENN(UND(ISTNV(VERGLEICH(ZEILE(Y24);$BI:$BI;0));ISTTEXT(BN25)="Wärme");"";INDIREKT("v"&VERGLEICH(ZEILE(Y24);$BI:$BI;0)))"

Es muss sicher anders sein - ich komme nur nicht drauf und habe schon verschiedene Kombinationen durch. Deshalb ja auch hier meine Anfrage. Muss sicherlich auf die Spalte "H" Bezug nehmen - aber eben das bekomme ich nicht hin. Vielleicht hast du noch eine Idee.

Gruß HHorst


  

Betrifft: AW: istnv(vergleich(... mit zusätzl. Textvergleich von: Jens
Geschrieben am: 20.11.2009 08:17:03

Hallo

Lad mal bitte die Datei hier hoch.

Gruß Jens


  

Betrifft: AW: istnv(vergleich(... mit zusätzl. Textvergleich von: HHorst
Geschrieben am: 20.11.2009 13:15:38

Hallo Jens,

hier ein der Teil der Datei:

https://www.herber.de/bbs/user/66060.zip

Gruß
HHorst


  

Betrifft: AW: istnv(vergleich(... mit zusätzl. Textvergleich von: HHorst
Geschrieben am: 25.11.2009 09:17:29

Hallo Jens,

hast du einmal dir die Datei angeschaut?

Gruß
HHorst