Microsoft Excel

Herbers Excel/VBA-Archiv

@Tino und alle Anderen: Mittelwert mit Makro | Herbers Excel-Forum


Betrifft: @Tino und alle Anderen: Mittelwert mit Makro von: Andre´
Geschrieben am: 14.02.2012 19:46:26

Hallo alle zusammen,

Tino hatte am 12.02.2012 eine Lösung zu folgenden Beitrag "Stunden Array"gegeben:

https://www.herber.de/forum/messages/1250364.html

Ich würde gern diese auf meine Daten anpassen, allerdings brauche ich den Mittelwert.

In dem angehängten Bsp. ist im Blatt 2 das Ergebnis wie es aussehen soll. Im Blatt 1 sind die Grunddaten.
Von der Spalte J und K soll der Mittelwert ausgegeben werden.

https://www.herber.de/bbs/user/78925.xlsx

Gibt es auch hierfür eine Makrolösung?

Vielen Dank im Voraus!

MFG Andre

  

Betrifft: AW: @Tino und alle Anderen: Mittelwert mit Makro von: Tino
Geschrieben am: 14.02.2012 21:03:04

Hallo,
versuch mal so.

https://www.herber.de/bbs/user/78926.xlsm

Mit Formel würde ich mit Summewenn()/Zählenwenn() den Mittelwert bilden.
In etwa so:

 ABC
111011
2123489,666666671,666666667
3Test 21002
4Test 640,80,5
5Test 485,50
6Test 7802
7Test 8571
8Test 101000

Formeln der Tabelle
ZelleFormel
B2=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A2;'1'!J$2:J$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A2)
C2=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A2;'1'!K$2:K$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A2)
B3=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A3;'1'!J$2:J$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A3)
C3=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A3;'1'!K$2:K$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A3)
B4=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A4;'1'!J$2:J$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A4)
C4=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A4;'1'!K$2:K$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A4)
B5=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A5;'1'!J$2:J$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A5)
C5=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A5;'1'!K$2:K$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A5)
B6=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A6;'1'!J$2:J$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A6)
C6=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A6;'1'!K$2:K$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A6)
B7=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A7;'1'!J$2:J$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A7)
C7=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A7;'1'!K$2:K$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A7)
B8=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A8;'1'!J$2:J$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A8)
C8=SUMMEWENN('1'!$A$2:$A$11;Tabelle1!$A8;'1'!K$2:K$11)/ZÄHLENWENN('1'!$A$2:$A$11;Tabelle1!$A8)



Gruß Tino


  

Betrifft: AW: @Tino und alle Anderen: Mittelwert mit Makro von: Andre´
Geschrieben am: 14.02.2012 21:40:28

Hallo Tino,
vielen Dank für die schnelle Antwort, es funktioniert wie gewünscht!

Ich brauche noch etwas Zeit, um zu verstehen was im Code abgeht.

Mit einer Formel hätte ich auch kein Problem, solche Dinge kläre ich üblicherweise über Pivot.

Mich hat alleine Deine Makrolösung vom 12.02. interessiert, die ich versucht habe auf den Mittelwert anzupassen.

Vielen Dank nochmals!!!

MFG Andre


Beiträge aus den Excel-Beispielen zum Thema "@Tino und alle Anderen: Mittelwert mit Makro "