Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert der letzten 4 Tabelleneinträgen

Betrifft: Mittelwert der letzten 4 Tabelleneinträgen von: Blue Hill
Geschrieben am: 12.11.2014 17:12:37

Hallo zusammen,
ich habe folgendes Problem:
Mein Arbeitsblatt enthält eine Tabelle (Tabelle1) mit mehreren Spalten. In einer Spalte sind Zahlen eingetragen, teilweise mit Lücken.
Ich benötige den Mittelwert der letzten 4 Einträge dieser Spalte (siehe rote Zelle).

Wie kann ich dies erreichen?

Gruß BlueHill

https://www.herber.de/bbs/user/93720.xlsx

  

Betrifft: AW: Mittelwert der letzten 4 Tabelleneinträgen von: Matze Matthias
Geschrieben am: 12.11.2014 18:14:16

Hi Blue Bill,
was ist falsch an deinem Ergebnis?
Verstehe nicht worauf du hinaus willst

entweder Mittelwert wie du es genommen hast oder

=Summe(B10:B14)/Anzahl(B10:B14)

Gruß Matze


  

Betrifft: AW: Mittelwert der letzten 4 Tabelleneinträgen von: Blue Hill
Geschrieben am: 12.11.2014 18:22:51

Naja, ich habe die Formel von Hand eingegeben! Wenn ich z.B in Zeile 11 einen Wert eingebe, nimmt sie den Mittelwert aus 5 Werten. Oder wenn ich den Inhalt aus Zeile 12 lösche nur von 3 statt 4 Werten.


  

Betrifft: Dann so,... von: Matze Matthias
Geschrieben am: 12.11.2014 18:40:57

Hi Blue Hill,

{=MITTELWERT(INDEX(B:B;KGRÖSSTE(ISTZAHL(B1:B14)*ZEILE(1:14);MIN(4;ANZAHL(B:B)))):B14)}

Matrixformel ,die Geschweiften Klammern nicht mit eingeben.
Die Formel mit Strg+Shift+Enter abschließen!!!


Gruß Matze


  

Betrifft: MITTELWERT() mit WENN() und KGRÖSSTE() ... von: neopa C (paneo)
Geschrieben am: 12.11.2014 18:34:08

Hallo BlueHill,

... z.B. so:

 GH
4Mittelwert ges17,5
5Mittelwert last 432,5

Formeln der Tabelle
ZelleFormel
H4=MITTELWERT(Tabelle1[Spalte2])
H5{=MITTELWERT(WENN((ZEILE(Tabelle1[Spalte2])>KGRÖSSTE(WENN(Tabelle1[Spalte2]<>"";ZEILE(Tabelle1[Spalte2])); 5))*(Tabelle1[Spalte2]<>""); Tabelle1[Spalte2]))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: MITTELWERT() mit WENN() und KGRÖSSTE() ... von: Blue Hill
Geschrieben am: 12.11.2014 18:40:23

Vielen Dank!
Ich habe zwischenzeitlich eine ähnliche Lsg gefunden, allerdings ist die Formel mindestens doppelt so lange und oft verschachtelt.


  

Betrifft: AW: MITTELWERT() mit WENN() und KGRÖSSTE() ... von: Blue Hill
Geschrieben am: 12.11.2014 18:59:28

Ich habe noch eine Abfrage eingebaut, welche die Formel abfängt, wenn weniger als 4 Werte enthalten sind, und nun bin ich vollends zufrieden.
Danke nochmals


  

Betrifft: AW: MITTELWERT() mit WENN() und KGRÖSSTE() ... von: Matze Matthias
Geschrieben am: 12.11.2014 19:16:56

Hi Blue Hill,
hast du meinen Vorschlag auch getestet?

Matze


  

Betrifft: AW: MITTELWERT() mit WENN() und KGRÖSSTE() ... von: Blue Hill
Geschrieben am: 12.11.2014 21:05:14

Sry, habe ich im Eifer übersehen! ja, auf den ersten Blick scheint er scheint auch zu gehen. Ich werde morgen mal einen Testlauf machen.

Danke


 

Beiträge aus den Excel-Beispielen zum Thema "Mittelwert der letzten 4 Tabelleneinträgen"