Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Tabelle auswerten
30.08.2013 16:41:13
Wolfango
Hallo zusammen,
ich habe eine Tabelle mit sehr vielen Namen. Siehe Beispiel:
https://www.herber.de/bbs/user/87104.xlsx
Jedem Namen sind Zahlen aus Zeile 1 zugeordnet (die Kreuze).
Nun möchte ich (via Formeln, kein VBA) auswerten, wem jeweils welche Zahlen zugeordnet sind.
Das gewünschte Ergebnis habe ich in Spalte L skizziert.
Voarb schon mal vielen Dank!
Gruß,
Wo

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Tabelle auswerten
30.08.2013 17:25:29
Erich
Hi,
mit einigen Hilfsspalten könnte das so gehen:
 BCDEFGHIJKLMNOPQR
1 123456789ErgebnisHilfHilfHilfHilfHilfHilf
2Weberx XXX    1, 3, 4, 53, 4, 54, 55   
3Huber    XX X X4, 5, 7, 95, 7, 97, 99   
4MeierXX   XXXx1, 2, 6, 7, 8, 92, 6, 7, 8, 96, 7, 8, 97, 8, 98, 99 
5SchmitzXX  X    1, 2, 52, 55    

Formeln der Tabelle
ZelleFormel
L2{=WENNFEHLER(INDEX($A$1:$K$1;KKLEINSTE(WENN($C2:$K2="x";SPALTE($C2:$K2)); SPALTE(A2)))&WENN(M2<>"";", "&M2;""); "")}
M2{=WENNFEHLER(INDEX($A$1:$K$1;KKLEINSTE(WENN($C2:$K2="x";SPALTE($C2:$K2)); SPALTE(B2)))&WENN(N2<>"";", "&N2;""); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich

Anzeige
AW: Tabelle auswerten
03.09.2013 13:06:52
Wolfango
Super! Die Formel macht genau das was ich möchte!
Dankeschön!!
Gruß,
Wo

314 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige