Microsoft Excel

Herbers Excel/VBA-Archiv

Berechnungen wenn Zellen #WERT! entalten

Betrifft: Berechnungen wenn Zellen #WERT! entalten von: Thomas
Geschrieben am: 19.08.2004 00:29:42

Hallo zusammen,
habe folgendes Problem:
Wenn ich aus einer Tabellenspalte, in der auch nur eine Zelle [#WERT!] enthällt den Mittelwert ermitteln will, zeigt Excel als Ergebins auch [#WERT!] an.
Kann mir da jemand helfen ?
Denn die Zellen mit [#WERT!] sind bei mir (bis jetzt) unvermeidbar. Excel sollte diese Zellen einfach bei der Berechnung nicht beachten. Wie binge ich es ihm bei ? Oder wodurch könnte ich die [#WERT!] erstzen, damit er es nimmt ?

Danke schon mal

  


Betrifft: AW: Berechnungen wenn Zellen #WERT! entalten von: Elmar Steigenberger
Geschrieben am: 19.08.2004 00:36:08

Hallo Thomas,

könntest Du nicht den #WERT! verhindern mit einer Wenn-Funktion, die nur rechnet, wenn er darf? undwenn er nicht darf, gibt die Wenn-Funktion zb 0 aus oder nichts ("")

Stell doch Deine Tabelle mal rein, dann kann man Dir eher helfen!

liebe e-Grüße

Elmar


  


Betrifft: AW: Berechnungen wenn Zellen #WERT! entalten von: Mac4
Geschrieben am: 19.08.2004 07:36:18

Hallo Thomas,

grundsätzlich gebe ich Elmar hier Recht - wenn es geht, solltest Du im Vorfeld durch Formelgestaltung #Wert versuchen zu vermeiden. Wenn das aber aus irgendwelchen Gründen nicht geht, geht auch folgendes (Deine Werte stehen in Spalte A):

{=MITTELWERT(WENN(ISTZAHL(A1:A100);A1:A100))}

Beachte bitte, dass es sich hier um eine Matrixformel handelt, Du musst die Formeleingabe mit Strg+Shift+Return abschließen, um die geschweiften Klammern zu erzeugen!

Marc (aus Köln)


  


Betrifft: Mittelwert mit Fehlerwerten - ohne Array von: Boris
Geschrieben am: 19.08.2004 09:16:11

Hi Marc,

arrayfrei ist diese Lösung und zudem superschnell:

=SUMMEWENN(A:A;"<1E+307")/ZÄHLENWENN(A:A;"<1E+307")

Grüße Boris


  


Betrifft: AW: Mittelwert mit Fehlerwerten - ohne Array von: Mac4
Geschrieben am: 19.08.2004 10:18:26

Hi Boris,

diese Variante vergesse ich regelmäßig - danke für den Hinweis!

Marc


  


Betrifft: AW: Danke an alle drei von: Thomas
Geschrieben am: 19.08.2004 21:22:29

Vielen Dank für Eure Beitäge, ich denke jetzt geht es wieder.
Thomas


 

Beiträge aus den Excel-Beispielen zum Thema "Berechnungen wenn Zellen #WERT! entalten"