Microsoft Excel

Herbers Excel/VBA-Archiv

Makrostart bei WENN-Funktion

Betrifft: Makrostart bei WENN-Funktion von: DIKA
Geschrieben am: 09.09.2004 19:59:23

Hallo zusammen
vielleicht kann mir jemand behilflich sein bei der Lösung dieses Problemes (für Excel-Kenner natürlich keines, aber ich bin leider nicht so fit in VBA).
Ich möchte ein Makro über eine WENN DANN Bedingung (wahrscheinlich mit Umweg über den Aufruf einer Funktion ?) starten und nicht über eine generelle WENN Abfrage in VBA. (Ich möchte diese WENN-Formel in andere Zellen kopieren können.

Leider ist das Ergebnis nicht das, was ich erwarte. Hier mal die Datei, in der mein Excel-Problem" detailiert bechrieben ist.

https://www.herber.de/bbs/user/10714.xls

Vielen Dank schon mal im voraus für die freundliche Unterstützung !!!
Gruß Dirk

  


Betrifft: AW: Makrostart bei WENN-Funktion von: Mixcel
Geschrieben am: 09.09.2004 20:21:22

hi ..

warum nicht über ein worksheet ereigniss wie

selection change oder worksheet calculate ereigniss ?

das sollte dann gehen ...

rechtsklick auf die tabelle - code anzeigen und bei tabelle ( im baum rechts ) doppelklicken - anschl. oben in der adressleiste auf die ereignisse gehn ...

Gruß


  


Betrifft: AW: Makrostart bei WENN-Funktion von: DIKA
Geschrieben am: 09.09.2004 20:31:19

Hallo Mixcel,
vielen Dank schon mal für Deine Antwort.
Mein Excel-Problem:Da ich den Aufruf nur haben möchte, wenn z.B. in $D$2;$D$6; $D$23 usw. per Wenn-bedingung das Makro aufgerufen werden soll. Ich möchte auf meinem Tabellenblatt bei Bedarf die entsprechenden Zeilen nach unten kopieren inkl der Wenn-Funktion und möchte nicht jedesmal die Code-Methode anpassen.
Ich hoffe, ich habe mein Problem jetzt geschärft dargestellt, vielleicht kannst Du mir jetzt besser unter die Arme greifen,
Gruß Dirk


  


Betrifft: AW: Makrostart bei WENN-Funktion von: Udo
Geschrieben am: 09.09.2004 21:13:24

Nutze das Calculate-Ereignis mit Abfrage, ob die Zelle den definierten Wert hat.

Udo


  


Betrifft: Warum einfach, wenn's auch kompliziert geht? von: Beate Schmitz
Geschrieben am: 09.09.2004 23:14:03

Hallo Dirk,

die einfache WENN-Formel kannst du doch nach unten kopieren, ohne jedes Makro. Ob nun deine aufwändige Funktion in der Formel steht oder nur:

Tabelle1
 AB
1109.09.2004
22Nix
32Nix
42Nix
53Nix
6109.09.2004
72Nix
8109.09.2004
Formeln der Tabelle
B1 : =WENN(A1=1;HEUTE();"Nix")
B2 : =WENN(A2=1;HEUTE();"Nix")
B3 : =WENN(A3=1;HEUTE();"Nix")
B4 : =WENN(A4=1;HEUTE();"Nix")
B5 : =WENN(A5=1;HEUTE();"Nix")
B6 : =WENN(A6=1;HEUTE();"Nix")
B7 : =WENN(A7=1;HEUTE();"Nix")
B8 : =WENN(A8=1;HEUTE();"Nix")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



das Ergebnis ist doch das gleiche!

Gruß,
Beate


  


Betrifft: AW: Makrostart bei WENN-Funktion von: hauke1965
Geschrieben am: 10.09.2004 13:41:01

versuche es einfach mal mit run in deiner Function..
vieleicht läuft´s

Function MakroStart()
run "MakroStart_Makro"

End Function

grüße
hauke


  


Betrifft: AW: Makrostart bei WENN-Funktion von: Udo
Geschrieben am: 10.09.2004 13:54:39

Probier das doch erstmal aus, bevor du sowas ins Forum stellst.

Udo


  


Betrifft: AW: Makrostart bei WENN-Funktion von: hauke1965
Geschrieben am: 11.09.2004 12:52:05

da hast du wohl recht... läuft nämlich auch nicht.. werde ich mir merken :-)
hauke


 

Beiträge aus den Excel-Beispielen zum Thema "Makrostart bei WENN-Funktion"