Herbers Excel-Forum - das Archiv

Werte in Abhängigkeit von Optionsfeldern berechnen

Bild

Betrifft: Werte in Abhängigkeit von Optionsfeldern berechnen
von: Willy

Geschrieben am: 14.12.2006 09:47:28
Ich suche eine Lösung wie man Zahlenwerte je nach Optionsfeldern berechnen kann.
Ausgangslage:
Exceltabelle mit 20 Tabellenblättern
Tabellenblatt 1 = Deckblatt
Tabellenblatt 2 - 20 = Produktblätter
Auf den Produktblättern stehen 3 Optionsfelder (nennen wirs mal Produkt A, Produkt B, Produkt C)
Jedes Tabellenblatt 2-20 ist einem der drei Produktgruppen zuzuordnen.
Im jeweiligen Tabellenblatt sind (vereinfacht) folgende Werte eingegeben.
Zelle A1 = Stückzahl
Zelle A2 = Einzelpreis
Zelle A3 = Gesamtpreis
Zelle B1 = Produktname
Auf dem Deckblatt der Exceltabelle (=Tabellenblatt 1) möchte ich nun folgende Darstellung erreichen
Produkt A:
Produktename Gesamtpreis
Produktname Gesamtpreis
Produktname Gesamtpreis
usw.
Zeile A15 = Summe aller Gesamtpreise aus Produkt A
Produkt B:
Produktename Gesamtpreis
Produktname Gesamtpreis
Produktname Gesamtpreis
usw.
Zeile A25 = Summe aller Gesamtpreise aus Produkt B
Produkt C:
Produktename Gesamtpreis
Produktname Gesamtpreis
Produktname Gesamtpreis
usw.
Zeile A35 = Summe aller Gesamtpreise aus Produkt C
Also in Abhängigkeit davon, welches Optionsfeld ausgewählt ist, soll eine Zuordung auf dem Deckblatt in den jeweiligen Produktbereich erfolgen. Wobei hier alle Spielarten möglich sind. D.h. im Extremfall stehen 19x (20 Tabellenblätter - Deckblatt) ein Produktname und Gesatpreis unter einem Produkt (A, B oder C). Oder es findet eine Zuordnung von X-Produkten auf Produkt A, B oder C statt.
Ich hoffe ich konnte es irgendwie verständlich rüberbringen, worum es mir geht und ich würde mich über Hilfe freuen.
Gruß Willy
Bild

Betrifft: AW: Werte in Abhängigkeit von Optionsfeldern berec
von: fcs

Geschrieben am: 14.12.2006 11:09:54
Hallo Willy,
in den Tabellen 2 bis 20 muss du den Optionsbuttons (am besten die aus der Symbolleiste Formular) unter Steuerelement formatieren eine Zelle als Ausgabeverknüpfung zuweisen. in meinem Beispiel hab ich C1 verwendent. Je nach gewähltem Button steht dann 1, 2 oder 3 in der verknüpften Zelle. Diesen Zellwert kann man dann im Deckblatt zur Auswertung verwenden.
Im Deckblatt bekommt man die Formeln am einfachsten hin, wenn man je Produktgruppe in einer Hilfspalte die Namen der Tabellen 2 bis 20 eintragt (Im Beispiel Spalte H). Dann kann man mit der Funktion INDIREKT auf die Daten in den einzelnen Tabellen zugreifen.
Die Spalte G (Anzeigen) hab ich eingefügt, damit man mit dem Autofilter ggf. die Zeilen ausblenden kann, in denen keine Produktdaten angezeigt werden.
Gruss
Franz
Beispiel Deckblatt
A                  B        C   D   E        F            G
1                                                    Hilfsspalten
2                                                    Tabellenname   anzeigen
3        Produktgruppe A   Gesamtpreis                                    Ja
4      Produkt Tabelle 2           125                          2         Ja
22                                                              20       Nein
23  Summe Produktgruppe A           375                                    Ja
24                                                                         Ja
25        Produktgruppe B   Gesamtpreis                                    Ja
26                                                               2       Nein
44     Produkt Tabelle 20            50                         20         Ja
45  Summe Produktgruppe B           300                                    Ja
46                                                                         Ja
47        Produktgruppe C   Gesamtpreis                                    Ja
48                                                               2       Nein
49      Produkt Tabelle 3           125                          3         Ja
66                                                              20       Nein
67  Summe Produktgruppe C        1574,5                                    Ja
Benutzte Formeln:
A4:  =WENN(INDIREKT("'"&F4&"'!C1")=1;INDIREKT("'"&F4&"'!B1");"")
A22:  =WENN(INDIREKT("'"&F22&"'!C1")=1;INDIREKT("'"&F22&"'!B1");"")
A26:  =WENN(INDIREKT("'"&F26&"'!C1")=2;INDIREKT("'"&F26&"'!B1");"")
A44:  =WENN(INDIREKT("'"&F44&"'!C1")=2;INDIREKT("'"&F44&"'!B1");"")
A48:  =WENN(INDIREKT("'"&F48&"'!C1")=3;INDIREKT("'"&F48&"'!B1");"")
A49:  =WENN(INDIREKT("'"&F49&"'!C1")=3;INDIREKT("'"&F49&"'!B1");"")
A66:  =WENN(INDIREKT("'"&F66&"'!C1")=3;INDIREKT("'"&F66&"'!B1");"")
B4:  =WENN(INDIREKT("'"&F4&"'!C1")=1;INDIREKT("'"&F4&"'!A3");"")
B22:  =WENN(INDIREKT("'"&F22&"'!C1")=1;INDIREKT("'"&F22&"'!A3");"")
B23:  =SUMME(B4:B22)
B26:  =WENN(INDIREKT("'"&F26&"'!C1")=2;INDIREKT("'"&F26&"'!A3");"")
B44:  =WENN(INDIREKT("'"&F44&"'!C1")=2;INDIREKT("'"&F44&"'!A3");"")
B45:  =SUMME(B26:B44)
B48:  =WENN(INDIREKT("'"&F48&"'!C1")=3;INDIREKT("'"&F48&"'!A3");"")
B49:  =WENN(INDIREKT("'"&F49&"'!C1")=3;INDIREKT("'"&F49&"'!A3");"")
B66:  =WENN(INDIREKT("'"&F66&"'!C1")=3;INDIREKT("'"&F66&"'!A3");"")
B67:  =SUMME(B48:B66)
F26:  =F4
F44:  =F22
F48:  =F4
F49:  =F5
F66:  =F22
G4:  =WENN(B4<>"";"Ja";"Nein")
G22:  =WENN(B22<>"";"Ja";"Nein")
G26:  =WENN(B26<>"";"Ja";"Nein")
G44:  =WENN(B44<>"";"Ja";"Nein")
G48:  =WENN(B48<>"";"Ja";"Nein")
G49:  =WENN(B49<>"";"Ja";"Nein")
G66:  =WENN(B66<>"";"Ja";"Nein")

Bild

Betrifft: AW: Werte in Abhängigkeit von Optionsfeldern berec
von: Willy
Geschrieben am: 14.12.2006 11:25:24
Hallo Franz,
da hast du dir viel Arbeit gemacht, herzlichen Dank dafür.
Du schreibst, du hast in der Beispieltabelle in den Spalten H einen Tabellennamen vergeben, gemeint ist damit Spalte F oder?
Bild

Betrifft: AW: Werte in Abhängigkeit von Optionsfeldern berec
von: fcs
Geschrieben am: 14.12.2006 12:21:50
Hallo Willy,
natürlich Spalte F und nicht H für den Eintrag der Tabellennamen.
Gruss
Franz
 Bild
Excel-Beispiele zum Thema "Werte in Abhängigkeit von Optionsfeldern berechnen"
Gruppe von Optionsfeldern kopieren und Makro zuweisen Synchronisieren von Optionsfeldern in verschiedenen Blättern
Neue Arbeitsmappen mit Optionsfeldern erstellen Quersumme berechnen
Arbeitsmappe alle 5 Minuten neu berechnen Wert aus 2. UserForm-ComboBox-Spalte berechnen
Aktuelle Zeit über UserForm eintragen und Rennzeit berechnen Verbleibende Nettoarbeitstage des Monats berechnen
Modalwert einer gefilterten Reihe berechnen Werte aus Zeichenfolgen filtern und berechnen