Kombinationen in Matrix suchen und Werte berechnen

Bild

Betrifft: Kombinationen in Matrix suchen und Werte berechnen
von: David
Geschrieben am: 16.07.2015 15:18:21

Hallo zusammen,
Leider bin ich auf der Suche im Web und in Foren nicht auf die gewünschte Lösung gestossen. Vielleicht habe ich auch die falschen Suchbegriffe verwendet.
Folgende Aufgabe: Ich möchte eine Materialflussanalyse machen. Als wie viele Produkte von Arbeitsplatz X nach Arbeitsplatz Y gehen. Im angefügten Excel File möchte ich also automatisch berechnen, dass von Arbeitsplatz "12160" nach Arbeitsplatz "QQ" gehen. Im Beispiel sind Artikel B und Artikel F betroffen. Diese haben einen Verbrauch von 40 und 1. In der gelben Zelle von Kombination 12160QQ soll also 41 stehen.
Ich hoffe ich habe mich einigermassen verständlich ausgedrückt und würde mich auf eure Unterstützung freuen.
https://www.herber.de/bbs/user/98863.xlsx
Spalte A: Artikel
Spalte B: Verbrauch
Spalte C bis G: Verschiedene Arbeitsplätze
Spalte H bis K: Jeweils vor- und nachgelagerter Arbeitsplatz
David

Bild

Betrifft: AW: Kombinationen in Matrix suchen und Werte berechnen
von: SF
Geschrieben am: 16.07.2015 15:29:26
Hola,
so?

=SUMMENPRODUKT((C2:F8=12160)*(D2:G8="qq")*(B2:B8))
Gruß,
steve1da

Bild

Betrifft: AW: Kombinationen in Matrix suchen und Werte berechnen
von: David
Geschrieben am: 16.07.2015 16:17:06
Ciao,
Wahnsinn. Es scheint zu funktionieren. Ich habe bei deine Formel leicht angepasst auf:

=SUMMENPRODUKT(($C$2:$F$8=$D$26)*($D$2:$G$8=I25)*($B$2:$B$8))
Wie bringe ich nun diese Formel auf einfachem Weg in jede Zelle der Matrix? Die Originalmatrix ist 100 Zeilen x 100 Spalten ;-/

Bild

Betrifft: AW: Kombinationen in Matrix suchen und Werte berechnen
von: SF
Geschrieben am: 16.07.2015 16:22:05
Hola,
meinst du nicht eher so?

=SUMMENPRODUKT(($C$2:$F$8=$D26)*($D$2:$G$8=E$25)*($B$2:$B$8))
Oder soll wirklich alles auf I25 bezogen werden?
Wenn nicht, musst du in meiner zweiten Formel nur noch C2:F8, D2:G8 und B2:B8 auf die jeweilige Matrix anpassen.
Gruß,
steve1da

Bild

Betrifft: AW: Kombinationen in Matrix suchen und Werte berechnen
von: David
Geschrieben am: 16.07.2015 17:05:32
Doch ;-)
Suuuuper
Habe es nun in meiner Originaldatei versucht. Irgendetwas stimmt noch nicht da der Wert #NV angezeigt wird. Kann es mit der Formatierung der Zellen zusammenhängen. Die Datenquelle ist aus SAP und dabei wurde zuerst alles in Textform ausgegeben.
Gruss
DAvid

Bild

Betrifft: AW: Kombinationen in Matrix suchen und Werte berechnen
von: SF
Geschrieben am: 16.07.2015 17:15:14
Hola,
Habe es nun in meiner Originaldatei versucht.
#NV bedeutet, dass etwas mit den Suchbereichen in der Formel nicht stimmt. Zeig sie doch mal!
Gruß,
steve1da

Bild

Betrifft: AW: Kombinationen in Matrix suchen und Werte berechnen
von: David
Geschrieben am: 16.07.2015 17:15:24
Yessssssss, funktioniert. Hatte noch ein Fehler drin. You saved my day ;-)
Hasta la proxima

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Kombinationen in Matrix suchen und Werte berechnen"