Microsoft Excel

Herbers Excel/VBA-Archiv

Zeile --> Spalte | Herbers Excel-Forum


Betrifft: Zeile --> Spalte von: Flo
Geschrieben am: 06.01.2010 09:49:49

Hi,

... ich ärgere mich sicher, wenn ich die Lösung sehe, aber ich komm nicht drauf:

Ich möchte aus einer Liste, in der immer eine Kunde:Produkt -Kombination untereinander steht, eine Liste, wo jedem Kunden die Produkte nebeneinander gestellt werden.

Die Anzahl der Produkte pro kunde kann sich von 1 - 50 ändern ...

siehe auch das Beispiel. https://www.herber.de/bbs/user/67002.xls

Danke bereits im Voraus,

lg Flo

  

Betrifft: AW: Zeile --> Spalte von: Erich G.
Geschrieben am: 06.01.2010 10:08:48

Hi Flo,
hast du hier schon mal nachgesehen? http://www.excelformeln.de/formeln.html?welcher=28

Und hier ein wenig für dich umgestellt:

 EFGHI
1ID_KundeID_Produkt   
21ABC 
32BED 
43EATG

Formeln der Tabelle
ZelleFormel
F2{=WENN(SPALTEN($A:A)>ZÄHLENWENN($A:$A;$E2); "";INDEX($B:$B;KKLEINSTE(WENN($A$1:$A$99=$E2;ZEILE($1:$99)); SPALTE(A1))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Zeile --> Spalte von: Flo
Geschrieben am: 06.01.2010 10:14:31

Hi - Super; Was ist KKLEINSTE im Englischen Excel, weisst Du das?

in excelformeln.de habe ich tatsächlich gesucht, aber leider nicht gefunden ...


Danke Flo


  

Betrifft: KKLEINSTE = SMALL (owT, Danke für Rückmeldg.) von: Erich G.
Geschrieben am: 06.01.2010 10:22:06




Beiträge aus den Excel-Beispielen zum Thema "Zeile --> Spalte"