Microsoft Excel

Herbers Excel/VBA-Archiv

Hauptsaison+Artikelnr. -> Preis Hauptsaison



Excel-Version: 8.0 (Office 97)

Betrifft: Hauptsaison+Artikelnr. -> Preis Hauptsaison
von: Thabatha - ich heiße so!
Geschrieben am: 02.06.2002 - 13:45:26

Hi alle zusammen!
Ich haben eine Blatt Rechnung und ein Blatt Daten [Preisliste].
In C13 erscheint Hauptsaison, Nebensaison oder garnichts. In A16:A25 wird die Artikelnummer eingeben. Nun soll in D16:D25 der Preis Hauptsaison oder Nebensaison ermittelt werden. Wie verknüpfe ich die Abfragen miteinander?
Habe folgende Formel:
=WENN(A16="";"";INDEX(Daten!D4:D13;VERGLEICH('Eingaben&Berechnungen'!A16;Daten!A4:A13;0);1))

Vielleicht kann mir hier jemand helfen...
Vielen Dank
Thab

  

Re: Hauptsaison+Artikelnr. -> Preis Hauptsaison
von: Heinz
Geschrieben am: 02.06.2002 - 16:23:06

Hallo Thab,

Wenn deine Preise in dem Blatt Daten spaltenweise Haupt.- Nebasaison, gar nichts angeordnet sind geht es mit sverweis am einfachsten.
Gib den Preisen auf Date den Namen "Preise".

In der Zelle D16 kannst du nun folgende Formal verwenden:

=sverweis(A16;Preise;wenn(c13="Hauptsaison";3;wenn(c13="Nebensaison";4;5));0)

Ich gehe davon aus, dass deine Preise folgendermaßen angeornet sind:

Spalte 1 ArtikelNr
Spalte 2 Bezeichnung
Spalte 3 Hauptsaisonspreis
Spalte 4 Nebensaisonpreis
Spalte 5 garnichts

Viel Glück dabei

Heinz