Microsoft Excel

Herbers Excel/VBA-Archiv

Umwandlung 1/100 nach 1/60 | Herbers Excel-Forum


Betrifft: Umwandlung 1/100 nach 1/60 von: ottgunter
Geschrieben am: 18.11.2009 16:12:35

Hallo guten Abend

Ich suche eine Lösung , die den Wert 1/100 z.B -144,85 in einen Wert von 1/60 z.B -144,51 umwandelt.

In Zelle A1 steht -144,85 in Zelle B1 soll dann -144,51 stehen. Ich hoffe mann kann mit dieser Erklärung etwas anfangen.

Gruß Gunter

  

Betrifft: AW: Umwandlung 1/100 nach 1/60 von: Björn B.
Geschrieben am: 18.11.2009 16:17:04

Hallo,

hat das was mit Zeiten zu tun?
1/100 Minuten in Sekunden anzeigen?

Also 144,59 + 0,01 = 145, richtig?

Gruß
Björn B.


  

Betrifft: AW: Umwandlung 1/100 nach 1/60 von: ottgunter
Geschrieben am: 18.11.2009 16:25:40

Hallo Björn

Hintern komma sollen nur die min erscheinen.
Orginal steht ja -144,85. Nun rechne ich 85*60, da kommt ja 5100 raus . also 51 min
Jetzt soll in Zelle B1 -144,51 stehen.
Oder wenn andere Zahlen stehen z. B 157.56 dann rechne ich 56*60 = 3360 also aufrunden auf 34.
Soll also in Zelle B1 157,34 stehen. Es gibt bei uns diese neue Stundenberechnung ab neues Jahr.

Gruß Gunter


  

Betrifft: Wie wäre es mit dieser Formel... von: Björn B.
Geschrieben am: 18.11.2009 16:32:05

...
=RUNDEN(ABRUNDEN(A1;0)+(A1-ABRUNDEN(A1;0))*0,6;2)

Wenn in A1 Dein Ausgangswert steht.
Bitte mal testen.

Gruß
Björn


  

Betrifft: AW: Danke Björn von: ottgunter
Geschrieben am: 18.11.2009 16:43:32

Hallo Björn

Das ist der volltreffer

Recht vielen Dank


  

Betrifft: noch ein Hinweis... von: Björn B.
Geschrieben am: 18.11.2009 16:53:49

Hallo,

erst mal danke für die Rückmeldung.

Das ganze hat einen kleinen Haken bzw. ne Fehlerquelle.
Wenn Du mit den Zahlen auch rechnest, dann darfst du nur die Ausgangszahlen nehmen, niemals die durch die Formel angepassten. Sonst stimmt gar nichts mehr.

Eigentlich "vergewaltigt" diese Formel den Wert so, dass er (für Deine Zwecke) "richtig" angezeigt wird.
Für Excel wird aber 0,5 immer 1/2 bleiben und niemals 5/6.
Verstanden?

Gruß
Björn


  

Betrifft: AW: ja alles klar von: ottgunter
Geschrieben am: 18.11.2009 17:06:13

Hallo

habs verstanden

Gruß Gunter


  

Betrifft: AW: noch ein Hinweis... von: BoskoBiati
Geschrieben am: 18.11.2009 19:27:39

Hallo Björn,

=Ganzzahl(a1)+rest(a1;100)*60%
bringt das gleiche Ergebnis.


  

Betrifft: Um Gottes Willen NEIN!!! von: Björn B.
Geschrieben am: 19.11.2009 10:52:14

Hallo,

was soll das denn jetzt?
Diese Formel bringt außer bei 0 immer ein anderes Ergebnis. Das ist ja kpl. falsch!

Bei Deiner Formel kommt (zumindest in meinem Excel) für -144,85 als Ergebnis -111,91???

Das nächste Mal vielleicht testen, bevor man so was ins Forum stellt ;-)

Gruß
Björn B.


  

Betrifft: AW: Um Gottes Willen NEIN!!! von: BoskoBiati
Geschrieben am: 19.11.2009 12:03:17

Hallo Björn,

getestet schon, aber nur mit positiven Zahlen und dann falsch übertragen. Es hätte Rest(a1;1) heißen müssen, dann hätte es auf jeden Fall für positive Zahlen funktioniert.

Es geht aber auch mit Ganzzahl:
Tabelle1

 AB
1-144,85-144,51

Formeln der Tabelle
ZelleFormel
B1=VORZEICHEN(A1)*(GANZZAHL(ABS(A1))+REST(ABS(A1); 1)*60%)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: Aha. von: Björn B.
Geschrieben am: 19.11.2009 13:14:07

Hallo,

warum versuchst du, meine Formel noch umständlicher zu machen???
Ich weiß, dass es noch andere Formel gibt.
Erich und Matthias haben bereits weitere Formeln genannt.
Die waren zumindest kürzer, über die Einfachheit lässt sich streiten.

Jetzt kommst Du, und machst mit Abstand die längste und umständlichste Formel?
Denn Sinn verstehe ich jetzt nicht ganz ;-)

Wenn ich mir jetzt noch ein paar Gedanken mache, dann schaffe ich es bestimmt noch länger :-)
Das will wahrscheinlich aber keiner wissen.

Egal.

Nicht böse gemeint :-)

Gruß
Björn B.


  

Betrifft: Umwandlung 1/100 nach 1/60 - kürzer von: Erich G.
Geschrieben am: 18.11.2009 18:35:17

Hi Gunter,
so wie in den Spalten C:D gehts noch etwas kürzer und einfacher:

 ABCD
1144,86144,52144,52144,52

Formeln der Tabelle
ZelleFormel
B1=RUNDEN(ABRUNDEN(A1;0)+(A1-ABRUNDEN(A1;0))*0,6;2)
C1=KÜRZEN(A1;)+RUNDEN(REST(A1;1)*0,6;2)
D1=KÜRZEN(A1;)+DM(REST(A1;1)*0,6)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: Bei negativem Stundenkonto falsches Ergebnis! von: Matthias5
Geschrieben am: 19.11.2009 08:51:38

Hallo Erich,

bei negativem Stundenkonto reicht diese Verkürzung nicht aus:

Tabelle1

 ABCDE
1-144,85-144,51-143,91-143,91-144,51
2144,85144,51144,51144,51144,51

verwendete Formeln
Zelle Formel
B1 =RUNDEN(ABRUNDEN(A1;0)+(A1-ABRUNDEN(A1;0))*0,6;2)
C1 =KÜRZEN(A1;)+RUNDEN(REST(A1;1)*0,6;2)
D1 =KÜRZEN(A1;)+DM(REST(A1;1)*0,6)
E1 =KÜRZEN(A1;)+DM(REST(ABS(A1);1)*0,6)*(1-2*(A1<0))

Tabellendarstellung in Foren Version 4.8

Gruß,
Matthias


  

Betrifft: Stimmt! - Zwei neue Formeln von: Erich G.
Geschrieben am: 19.11.2009 09:20:14

Hi Matthias,
stimmt, das Vorzeichen hatte ich einfach übersehen. :-]
So geht es auch - in Spalte C länger als in Spalte D:

 ABCD
1144,86144,52144,52144,52
2-144,86-144,52-144,52-144,52

Formeln der Tabelle
ZelleFormel
B1=RUNDEN(ABRUNDEN(A1;0)+(A1-ABRUNDEN(A1;0))*0,6;2)
C1=KÜRZEN(A1;)+VORZEICHEN(A1)*DM(REST(ABS(A1); 1)*0,6)
D1=KÜRZEN(A1;)+DM((A1-KÜRZEN(A1;))*0,6)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Stimmt! - Zwei neue Formeln von: ottgunter
Geschrieben am: 20.11.2009 21:32:16

Hallo alle zusammen

Habe heute erst euern nachtrag gesehen.
Ich habe aber immer noch eine diff
Habe aber immer noch ein Problem.
in AP1 139,84 umrechnung in aq1 = 139,50 jetzt möchte ich eine Diff in Zelle as1 haben. 160,00 ist der soll. Was muß dort rengeschrieben werden.

Gruß Gunter


  

Betrifft: AW: Stimmt! - Zwei neue Formeln von: Björn B.
Geschrieben am: 20.11.2009 23:02:34

Hallo Gunter,

hier die gewünschte Formel:

=160-KÜRZEN(AQ1;)+(0,6+KÜRZEN(AQ1;)-AQ1)
Und jetzt dürfen alle anderen das ganze wieder kürzer darstellen :-)
Bin mal gespannt, was ihr wieder zaubert...

Die Formel setzt allerdings voraus, das in AQ1 keine "ungültigen" Werte stehen, also z.B. 139,67.
Sonst stimmt es nicht, wenn das auch noch geprüft werden soll, muss die Formel entsprechend erweitert werden.

Gruß
Björn


  

Betrifft: Formel für Differenz von: Erich G.
Geschrieben am: 21.11.2009 01:23:48

Hi Gunter,
so genau habe ich nicht verstanden, was du nun rechnen möchtest.

Soll das so sein wie hier in Spalte D oder E?

 ABCDEFGHI
1IstSollDiff1Diff2 aDiff2 bDiff3 aDiff3 b Umrechn
20160160,60-160,00-160,00160,00160,00 0,00
30,07160160,53-159,56-159,56159,56159,56 0,04
412316037,60-37,00-37,0037,0037,00 123,00
5139,516021,10-20,30-20,3020,3020,30 139,30
6139,8416020,76-20,10-20,1020,1020,10 139,50
7159,51601,10-0,30-0,300,300,30 159,30
81601600,600,000,000,000,00 160,00
9160,21600,400,120,12-0,12-0,12 160,12
10200160-39,4040,0040,00-40,00-40,00 200,00

Formeln der Tabelle
ZelleFormel
C2=160-KÜRZEN(A2;)+(0,6+KÜRZEN(A2;)-A2)
D2=KÜRZEN(A2-160;)+DM((A2-160-KÜRZEN(A2-160;))*0,6)
E2=KÜRZEN(A2-B2;)+DM((A2-B2-KÜRZEN(A2-B2;))*0,6)
F2=KÜRZEN(160-A2;)+DM((160-A2-KÜRZEN(160-A2;))*0,6)
G2=KÜRZEN(B2-A2;)+DM((B2-A2-KÜRZEN(B2-A2;))*0,6)
I2=KÜRZEN(A2;)+DM((A2-KÜRZEN(A2;))*0,6)

Björn, deine Formel (Spalte C) verstehe ich nicht.

Spalte I ist nur zur Info.

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Formel für Differenz von: ottgunter
Geschrieben am: 21.11.2009 06:45:42

Hallo guten morgrn
Es ist ein kompliziertes Thema

Ich habe mal zur besseren darstellung ein teil dieses Planes renkopiert
https://www.herber.de/bbs/user/66071.xlsm

Die blau dargestellten Zellen sind das Problem

Gruß Gunter


  

Betrifft: besser XLS als XLSX oder XLSM (owT) von: Erich G.
Geschrieben am: 21.11.2009 09:29:03

(ohne weiteren Text)


  

Betrifft: AW: besser XLS als XLSX oder XLSM (owT) von: ottgunter
Geschrieben am: 21.11.2009 14:07:25

Hallo
Vieleicht hilft das weiter
Januar

 ANAOAPAQARASATAUAVAWAXAYAZ
2Soll IstIstDiff M/FM/F-StdM/F-StdÜberstÜberstVerrech.Verrech.
3Std Std 1/100Std 1/601/1001/60VormGesamt 1/100Gesamt 1/6025%GesamtStunden 1/100Stunden 1/60
4160,00 17,4817,29-142,52  -142,31  -142,52  -142,31   -142,52  -142,31  
5160,00   -160,00  -160,00  -160,00  -160,00   -160,00  -160,00  
6160,00   -160,00  -160,00  -160,00  -160,00   -160,00  -160,00  
7160,00 157,323,28-2,68  -2,41  -2,68  -2,41   -2,68  -2,41  

Formeln der Tabelle
ZelleFormel
AN4=AE60+AO4
AP4=SUMME(B4:AL4)+ZÄHLENWENN(B4:AL4;"T")*8+ZÄHLENWENN(B4:AL4;"RTW")*17,48+ZÄHLENWENN(B4:AL4;"KT")*5,9+ZÄHLENWENN(B4:AL4;"sT")*8+ZÄHLENWENN(B4:AL4;"U")*8+ZÄHLENWENN(B4:AL4;"K")*8+ZÄHLENWENN(B4:AL4;"A")*8+ZÄHLENWENN(B4:AL4;"RTW1")*17,48+ZÄHLENWENN(B4:AL4;"RTW2")*17,48+ZÄHLENWENN(B4:AL4;"NEF")*17,48+ZÄHLENWENN(B4:AL4;"RTW3")*17,48+ZÄHLENWENN(B4:AL4;"RTW4")*17,48+ZÄHLENWENN(B4:AL4;"RTW5")*17,48+ZÄHLENWENN(B4:AL4;"RTWK")*17,48+ZÄHLENWENN(B4:AL4;"Ur")*8+ZÄHLENWENN(B4:AL4;"RTH")*8,45+ZÄHLENWENN(B4:AL4;"sD")*6,55+ZÄHLENWENN(B4:AL4;"D")*6,55+ZÄHLENWENN(B4:AL4;"B")*8+ZÄHLENWENN(B4:AL4;"8")*8+ZÄHLENWENN(B4:AL4;"LS")*12+ZÄHLENWENN(B4:AL4;"W")*3+ZÄHLENWENN(B4:AL4;"KT8")*8,27+ZÄHLENWENN(B4:AL4;"KTWK")*6,55
AQ4=RUNDEN(ABRUNDEN(AP4;0)+(AP4-ABRUNDEN(AP4;0))*0,6;2)
AR4=(AP4-AN4)
AS4=RUNDEN(ABRUNDEN(AR4;0)+(AR4-ABRUNDEN(AR4;0))*0,6;2)
AU4=SUMME(AR4+AT4+BG4)
AV4=RUNDEN(ABRUNDEN(AU4;0)+(AU4-ABRUNDEN(AU4;0))*0,6;2)
AX4=AW4
AY4=SUMME(AU4+AX4)
AZ4=RUNDEN(ABRUNDEN(AY4;0)+(AY4-ABRUNDEN(AY4;0))*0,6;2)
AN5=AE60+AO5
AP5=SUMME(B5:AL5)+ZÄHLENWENN(B5:AL5;"T")*8+ZÄHLENWENN(B5:AL5;"RTW")*17,48+ZÄHLENWENN(B5:AL5;"KT")*5,9+ZÄHLENWENN(B5:AL5;"sT")*8+ZÄHLENWENN(B5:AL5;"U")*8+ZÄHLENWENN(B5:AL5;"K")*8+ZÄHLENWENN(B5:AL5;"A")*8+ZÄHLENWENN(B5:AL5;"RTW1")*17,48+ZÄHLENWENN(B5:AL5;"RTW2")*17,48+ZÄHLENWENN(B5:AL5;"NEF")*17,48+ZÄHLENWENN(B5:AL5;"RTW3")*17,48+ZÄHLENWENN(B5:AL5;"RTW4")*17,48+ZÄHLENWENN(B5:AL5;"RTW5")*17,48+ZÄHLENWENN(B5:AL5;"RTWK")*17,48+ZÄHLENWENN(B5:AL5;"Ur")*8+ZÄHLENWENN(B5:AL5;"RTH")*8,45+ZÄHLENWENN(B5:AL5;"sD")*6,55+ZÄHLENWENN(B5:AL5;"D")*6,55+ZÄHLENWENN(B5:AL5;"B")*8+ZÄHLENWENN(B5:AL5;"8")*8+ZÄHLENWENN(B5:AL5;"LS")*12+ZÄHLENWENN(B5:AL5;"W")*3+ZÄHLENWENN(B5:AL5;"KT8")*8,27+ZÄHLENWENN(B5:AL5;"KTWK")*6,55
AQ5=RUNDEN(ABRUNDEN(AP5;0)+(AP5-ABRUNDEN(AP5;0))*0,6;2)
AR5=(AP5-AN5)
AS5=RUNDEN(ABRUNDEN(AR5;0)+(AR5-ABRUNDEN(AR5;0))*0,6;2)
AU5=SUMME(AR5+AT5+BG5)
AV5=RUNDEN(ABRUNDEN(AU5;0)+(AU5-ABRUNDEN(AU5;0))*0,6;2)
AX5=AW5
AY5=SUMME(AU5+AX5)
AZ5=RUNDEN(ABRUNDEN(AY5;0)+(AY5-ABRUNDEN(AY5;0))*0,6;2)
AN6=AE60+AO6
AP6=SUMME(B6:AL6)+ZÄHLENWENN(B6:AL6;"T")*8+ZÄHLENWENN(B6:AL6;"RTW")*17,48+ZÄHLENWENN(B6:AL6;"KT")*5,9+ZÄHLENWENN(B6:AL6;"sT")*8+ZÄHLENWENN(B6:AL6;"U")*8+ZÄHLENWENN(B6:AL6;"K")*8+ZÄHLENWENN(B6:AL6;"A")*8+ZÄHLENWENN(B6:AL6;"RTW1")*17,48+ZÄHLENWENN(B6:AL6;"RTW2")*17,48+ZÄHLENWENN(B6:AL6;"NEF")*17,48+ZÄHLENWENN(B6:AL6;"RTW3")*17,48+ZÄHLENWENN(B6:AL6;"RTW4")*17,48+ZÄHLENWENN(B6:AL6;"RTW5")*17,48+ZÄHLENWENN(B6:AL6;"RTWK")*17,48+ZÄHLENWENN(B6:AL6;"Ur")*8+ZÄHLENWENN(B6:AL6;"RTH")*8,45+ZÄHLENWENN(B6:AL6;"sD")*6,55+ZÄHLENWENN(B6:AL6;"D")*6,55+ZÄHLENWENN(B6:AL6;"B")*8+ZÄHLENWENN(B6:AL6;"8")*8+ZÄHLENWENN(B6:AL6;"LS")*12+ZÄHLENWENN(B6:AL6;"W")*3+ZÄHLENWENN(B6:AL6;"KT8")*8,27+ZÄHLENWENN(B6:AL6;"KTWK")*6,55
AQ6=RUNDEN(ABRUNDEN(AP6;0)+(AP6-ABRUNDEN(AP6;0))*0,6;2)
AR6=(AP6-AN6)
AS6=RUNDEN(ABRUNDEN(AR6;0)+(AR6-ABRUNDEN(AR6;0))*0,6;2)
AU6=SUMME(AR6+AT6+BG6)
AV6=RUNDEN(ABRUNDEN(AU6;0)+(AU6-ABRUNDEN(AU6;0))*0,6;2)
AX6=AW6
AY6=SUMME(AU6+AX6)
AZ6=RUNDEN(ABRUNDEN(AY6;0)+(AY6-ABRUNDEN(AY6;0))*0,6;2)
AN7=AE60+AO7
AP7=SUMME(B7:AL7)+ZÄHLENWENN(B7:AL7;"T")*8+ZÄHLENWENN(B7:AL7;"RTW")*17,48+ZÄHLENWENN(B7:AL7;"KT")*5,9+ZÄHLENWENN(B7:AL7;"sT")*8+ZÄHLENWENN(B7:AL7;"U")*8+ZÄHLENWENN(B7:AL7;"K")*8+ZÄHLENWENN(B7:AL7;"A")*8+ZÄHLENWENN(B7:AL7;"RTW1")*17,48+ZÄHLENWENN(B7:AL7;"RTW2")*17,48+ZÄHLENWENN(B7:AL7;"NEF")*17,48+ZÄHLENWENN(B7:AL7;"RTW3")*17,48+ZÄHLENWENN(B7:AL7;"RTW4")*17,48+ZÄHLENWENN(B7:AL7;"RTW5")*17,48+ZÄHLENWENN(B7:AL7;"RTWK")*17,48+ZÄHLENWENN(B7:AL7;"Ur")*8+ZÄHLENWENN(B7:AL7;"RTH")*8,45+ZÄHLENWENN(B7:AL7;"sD")*6,55+ZÄHLENWENN(B7:AL7;"D")*6,55+ZÄHLENWENN(B7:AL7;"B")*8+ZÄHLENWENN(B7:AL7;"8")*8+ZÄHLENWENN(B7:AL7;"LS")*12+ZÄHLENWENN(B7:AL7;"W")*3+ZÄHLENWENN(B7:AL7;"KT8")*8,27+ZÄHLENWENN(B7:AL7;"KTWK")*6,55
AQ7=160-KÜRZEN(AP7;)+(0,6+KÜRZEN(AP7;)-AP7)
AR7=(AP7-AN7)
AS7=KÜRZEN(AR7;)+VORZEICHEN(AR7)*DM(REST(ABS(AR7); 1)*0,6)
AU7=SUMME(AR7+AT7+BG7)
AV7=RUNDEN(ABRUNDEN(AU7;0)+(AU7-ABRUNDEN(AU7;0))*0,6;2)
AX7=AW7
AY7=SUMME(AU7+AX7)
AZ7=RUNDEN(ABRUNDEN(AY7;0)+(AY7-ABRUNDEN(AY7;0))*0,6;2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Gunter


  

Betrifft: vielleicht hilft das weiter, ... von: Erich G.
Geschrieben am: 21.11.2009 15:48:47

Hi Gunter,
wenn du jetzt noch schreibst, wo das Problem ist, genauer:

In welcher Zelle der Tabelle steht jetzt ein falscher Wert?

Welcher richtige Wert sollte stattdessen in dieser Zelle stehen?

Geht es um den Wert in Zelle AQ7? Darin steht m. E. eine falsche Formel.
In Zeile 6 (und den Zeilen davor) stehen korrekte Formeln - die kannst du nach unten kopieren.

Wenn es das jetzt nicht war: Ja, dann musst du das Problem genauer erklären.

Noch eine Frage:
Findest du nicht auch, dass so riesige Zahlen wie in deinem letzten Post hier nicht besonders übersichtlich sind?
Und Spalten, die für das Problem unwichtig sind, bräuchtest du hier gar nicht darzustellen.

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: vielleicht hilft das weiter, ... von: ottgunter
Geschrieben am: 21.11.2009 16:29:00

Hallo Erich

Ab neues Jahr arbeiten wir mit den blau gekennzeichneten Zahlen. Vorher lautete die Stunden z. B. -111,64
In der neuen wird nur bis 60 min geschrieben Z.B. -111,59

In AN4 stehen die sollstunden die sich ja Monatlich ändern können. z.B. 184 In diesen Fall sind es 160
In Zelle AQ4 steht wieviel stunden bereits im Plan eingetragen wurde
In AS4 sind die Stunden angegeben, die zwischen AN4 und AQ4 in diff stehen.
Wenn ich jetzt rechne 160 - 17,29 = 142,71 Es müßte aber 142,31 sein
Wenn ich die weißen Felder rechne 160-17,48=142,52 habe ich keine Diff.
Also mein problem ist, daß ich in den blau markierten zelle Aq und AS eine diff habe im bezug zu den soll stunden AN .

Gruß Gunter


,


  

Betrifft: AW: vielleicht hilft das weiter, ... von: ottgunter
Geschrieben am: 21.11.2009 16:53:58

Hallo noch ein kleiner Nachtrag

Die umrechnung soll volgender maßen sein

53,40 jetzt rechne ich 60*40 ergibt 24 also 53,24

17,80 60*80 ergibt 48 also 17,48 usw.

so soll die umrechnung aussehen

Gruß Gunter


  

Betrifft: AW: vielleicht hilft das weiter, ... von: Erich G.
Geschrieben am: 21.11.2009 18:15:42

Hi Gunter,
nun hast du ein ganz prinzipielles Problem mit dieser Darstellung. Neu sollte dir das aber nicht sein:

Björn hat in seinem Beitrag vom 18.10.2009 16:53:49 geschrieben:

Das ganze hat einen kleinen Haken bzw. ne Fehlerquelle.
Wenn Du mit den Zahlen auch rechnest, dann darfst du nur die Ausgangszahlen nehmen, 
niemals die durch die Formel angepassten. Sonst stimmt gar nichts mehr.

Eigentlich "vergewaltigt" diese Formel den Wert so, 
dass er (für Deine Zwecke) "richtig" angezeigt wird.
Für Excel wird aber 0,5 immer 1/2 bleiben und niemals 5/6.
Verstanden?
Jetzt schreibst du:
"Ab neues Jahr arbeiten wir mit den blau gekennzeichneten Zahlen."
und
"Wenn ich jetzt rechne 160 - 17,29 = 142,71 Es müßte aber 142,31 sein."

Der Fehler ist: Du versuchst, mit diesen Darstellungen zu rechnen. DAS GEHT NICHT !
(jedenfalls nicht so einfach)

Wir befinden uns (auch in Excel) im Dezimalsystem, du hast da ein Mischsystem aus Dezimal und 1/60.

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: noch mal deutlicher von: Erich G.
Geschrieben am: 21.11.2009 18:32:44

Hi Gunter,
bei der 1/60-Darstellung solltest du einfach davon ausgehen, dass das KEINE ZAHLEN zum Rechnen sind,
sondern nur Texte zum Ansehen.

Ich hab die Umrechnungsformel jetzt so geschrieben, dass da tatsächlich Text rauskommt.
Text - hier in den gelben Spalten - wird auch in Excel normalerweise linksbündig dargestellt.
Zahlen stehen dagegen rechtsbündig:

 ABCDEFG
1IstIst 1/60SollDiffDiff 1/60 Diff 1/60
20,000:00160-160,00-160:00 -160:00
30,490:29160-159,51-159:31 -159:31
4123,00123:00160-37,00-37:00 -37:00
5139,50139:30160-20,50-20:30 -20:30
6139,84139:50160-20,16-20:10 -20:10
7159,50159:30160-0,500:30 0:30
8160,00160:001600,000:00 0:00
9160,20160:121600,200:12 0:12
10200,00200:0016040,0040:00 40:00
11ZahlTEXTZahlZahlTEXT TEXT

Formeln der Tabelle
ZelleFormel
B2=KÜRZEN(A2;)&":"&TEXT(100*(A2-KÜRZEN(A2;))*0,6;"00")
D2=A2-C2
E2=KÜRZEN(D2;)&":"&TEXT(100*ABS(D2-KÜRZEN(D2;))*0,6;"00")
G2=KÜRZEN(A2-C2;)&":"&TEXT(100*ABS(A2-C2-KÜRZEN(A2-C2;))*0,6;"00")

Nur mit den grün unterlegten Zahlen kannst du weiterrechnen.

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Danke Erich von: ottgunter
Geschrieben am: 22.11.2009 18:19:17


Habt alle noch mal recht herzlichen Dank


Gruß Gunter


Beiträge aus den Excel-Beispielen zum Thema "Umwandlung 1/100 nach 1/60"