Microsoft Excel

Herbers Excel/VBA-Archiv

Gestutzter Mittelwert - nur obere Werte ausschlies | Herbers Excel-Forum


Betrifft: Gestutzter Mittelwert - nur obere Werte ausschlies von: Benjamin
Geschrieben am: 26.01.2012 11:26:35

Hallo zusammen
ich habe folgendes Problem.
Ich muss aus einer Tabelle einen Mittelwert erzeugen, indem (nicht wie beim gestutzten Mittel oben und unten abgeschnitten wird), die oberen 5 % nicht berücksichtigt werden.

Also z.B. 10 % von :
1
2
3
4
5
6
7
8
9
10

= Mittelwert von 5 (Zahlen 1 - 9 werden berücksichtigt, die Zahl 10 nicht)

Könnt ihr mir helfen?

Viele Grüsse
benjamin

  

Betrifft: AW: Gestutzter Mittelwert - nur obere Werte ausschlies von: Josef Ehrensberger
Geschrieben am: 26.01.2012 11:31:44


Hallo Benjamin,

so?

Tabelle2

 ABC
11 5
22  
33  
44  
55  
66  
77  
88  
99  
1010  

Formeln der Tabelle
ZelleFormel
C1=MITTELWERT(A1:INDEX(A:A;ANZAHL(A:A)*0,9))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: geht so leider nicht von: Benjamin
Geschrieben am: 26.01.2012 11:43:15

Hallo Sepp
das hilft leider nicht.
Denn da die Zahlen nicht sortiert sind (und das auch leider nicht gewünscht ist) würde in Deinem Beispiel die 10 weggenommen werden.
Dreht man die Reihenfolge der Zahlen einmal um, wird die 1 nicht Berücksichtigt. und der Mittelwert wäre 6.

Dennoch vielen Dank!

Viele Grüsse
Benjamin


  

Betrifft: AW: geht so leider nicht von: Josef Ehrensberger
Geschrieben am: 26.01.2012 12:08:52


Hallo Benjamin,

dann halt so.

Tabelle2

 ABC
110 5
22  
33  
49  
55  
66  
77  
88  
94  
101  

Formeln der Tabelle
ZelleFormel
C1{=MITTELWERT(WENN(($A$1:$A$100<>"")*($A$1:$A$100<=(MAX($A$1:$A$100)*0,9)); $A$1:$A$100))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: geht so leider nicht von: mpb
Geschrieben am: 26.01.2012 14:20:59

Hallo Sepp,

Du rechnest den Mittelwert für alle Zahlen aus, die kleiner als 90% des Maximums sind. Wenn ich Benjamin richtig verstehe, möchte er den Mittelwert der 90% kleinsten Zahlen. Das ist aber etwas anderes. Für diesen Fall käme ich auf Folgende Matrixformel:

=SUMME(((A1:A11)<=(KKLEINSTE(A1:A11;RUNDEN(ANZAHL(A1:A11)*0,9;0))))*(A1:A11))/SUMME(((A1:A11)< =(KKLEINSTE(A1:A11;RUNDEN(ANZAHL(A1:A11)*0,9;0))))*1)


Ich habe 11 Werte genommen, weil dann die 90% kleinsten Werte 9,9 Werte wären, also ein Ganzzahligkeitsproblem auftritt, dass bei Benjamins Beispiel untergeht.

Gruß
Martin


  

Betrifft: AW: geht so leider nicht von: Benjamin
Geschrieben am: 26.01.2012 15:27:49

Hallo Martin

mhh ich habe mal Deine Matrixformel durchgespielt. Wenn Du z.b.
10
10
10
10
10
10
10
10
10
1
1
hast, würde mit Deiner Formel 46.0 herauskommen, was auch nicht sein kann.

Sepp, bei Deiner Formel fürde für die Gleiche Zahlenfolge 1.0 herauskommen, was auch nicht stimmt.


Ich gehe daher davon aus, dass ich schlecht erklärt habe, was ich erreichen möchte.


Ich möchte, dass ich bei z.B. 11 Zahlen, den durchschnitt aus den niedrigsten 90% Zahlen bilden (also im Beispiel wären 90% von 11 Zahlen gerundet 1 Zahl, also möchte ich den durchschnitt der 10 niedrigsten Zahlen bilden. Also, im Beispiel 8.2)

Viele Grüsse
Benjamin


  

Betrifft: AW: geht so leider nicht von: Josef Ehrensberger
Geschrieben am: 26.01.2012 15:42:52


Hallo Benjamin,

Tabelle2

 ABC
110 8,20
210  
310  
410  
510  
610  
710  
810  
910  
101  
111  
12   

Formeln der Tabelle
ZelleFormel
C1{=MITTELWERT(KKLEINSTE(A1:A11;ZEILE(A1:INDEX(A:A;AUFRUNDEN(ANZAHL(A:A)*0,9;)))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: geht so leider nicht von: Benjamin
Geschrieben am: 26.01.2012 16:33:45

perfekt. danke!


Beiträge aus den Excel-Beispielen zum Thema "Gestutzter Mittelwert - nur obere Werte ausschlies"