Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

VBA Spalten einfügen mit Schlüsselnr

VBA Spalten einfügen mit Schlüsselnr
09.06.2017 12:14:18
MB12
Hallo zusammen,
ich erstelle regelmäßige Auswertungen aus Access.
Hier muss ich 2 Exporte durchführen, in einem Workbook speichern und - das ist hier die Aufgabe - die Daten in einem Blatt zusammenführen.
Ohne Makro würde ich mit INDEX und VERGLEICH arbeiten,
aber das soll ein Teil meines Makros werden.
Die Anzahl der jeweiligen Zeilen ändert sich jedes Mal.
Gemeinsamer Schlüssel für beide Tabellenblätter ist die Projektnummer
Das Ergebnis soll - welch Wunder - im Blatt "Ergebnis1" erscheinen
Könnt Ihr mich kurz vor dem Wochenende unterstützen?
Beispieldatei:
https://www.herber.de/bbs/user/114154.xlsx
Herzlichen Dank im Voraus
Margarete

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Sverweis()
09.06.2017 12:31:00
ransi
Hallo Margarete,
Für das Problem hat irgendein schlauer Kopf den Sverweis() erfunden.
Schau mal ob du dich damit anfreunden kannst:
Ergebnis1

 ABCDE
1  Projekt_NummerProjekt_BZAuftraggeber_Matchcode
2BereichKategorieProjekt-/ MaschinennummerMaschinentypKunde
3AEins1234567-100ABCKunde1
4BZweidreiviertel234567-8457DEFKunde2
5#NV#NV555555-200AACKunde9
6ADrei1111111-444444KLMNKunde3
7     

Formeln der Tabelle
ZelleFormel
A3=SVERWEIS($C3;Kategorie!$A:$C;2;)
B3=SVERWEIS($C3;Kategorie!$A:$C;3;)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
ransi
Anzeige
wennfehler(Sverweis();"")
09.06.2017 12:33:12
ransi
Damit das NV verschwindet:
Ergebnis1

 ABCDE
1  Projekt_NummerProjekt_BZAuftraggeber_Matchcode
2BereichKategorieProjekt-/ MaschinennummerMaschinentypKunde
3AEins1234567-100ABCKunde1
4BZweidreiviertel234567-8457DEFKunde2
5  555555-200AACKunde9
6ADrei1111111-444444KLMNKunde3
7     

Formeln der Tabelle
ZelleFormel
A3=WENNFEHLER(SVERWEIS($C3;Kategorie!$A:$C;2;); "")
B3=WENNFEHLER(SVERWEIS($C3;Kategorie!$A:$C;3;); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
ransi
Anzeige
AW: wennfehler(Sverweis();"") - nee, VBA
09.06.2017 13:29:23
MB12
Hi Ransi,
die Dateien werden jedesmal neu erzeugt - deshalb möchte ich das mit VBA lösen.
Trotzdem lieben Dank
Gruß und schönes WE
AW: VBA Spalten einfügen mit Schlüsselnr
09.06.2017 13:57:03
ransi
Hallo MArgarete,
Teste mal dies:
Option Explicit

Sub machs()
    Dim arr
    Dim L As Long
    Dim Bereich As Range
    With Sheets("Ergebnis1")
        Set Bereich = .Range(.Range("A3"), .Cells(.Rows.Count, 3).End(xlUp))
        arr = Bereich.Value
        On Error Resume Next
        For L = 1 To UBound(arr)
            arr(L, 1) = WorksheetFunction.VLookup(arr(L, 3), Sheets("Kategorie").Range("A:C"), 2, 0)
            arr(L, 2) = WorksheetFunction.VLookup(arr(L, 3), Sheets("Kategorie").Range("A:C"), 3, 0)
        Next
    End With
    Bereich = arr
End Sub



ransi
Anzeige
Genau das!
09.06.2017 14:16:41
MB12
Danke schön, Ransi -
You made my day :-)
...und diese Lösung werde ich künftig immer wieder benötigen.
Gruß, Margarete

315 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige