Excel Werte zusammenfassen mit Suche

Bild

Betrifft: Excel Werte zusammenfassen mit Suche
von: Helmut Maier
Geschrieben am: 14.07.2015 11:05:22

Hallo Excel Forum,
ich habe aktuell ein Problem in Excel bei dem ich nicht mehr weiter komme.
Unter folgendem Link könnt Ihr meine Excel Tabelle abrufen: https://www.herber.de/bbs/user/98810.xlsx
Ich habe in Spalte C die Projekt ID´s zu denen die User in Spalte G zugeordnet sind.
Nun möchte ich, dass wenn in der Spalte mit den Projekt ID ein Wert mehrmals vorkommt, dass die Werte aus der zugehörigen Zeile (User) zusammengefasst werden.
Beispiel:
Zeile 7 - Proj ID: 22 User: mrup
Zeile 8 - Proj ID: 22 User: gngr
Zeile 9 - Proj ID: 22 User: tfue
Zusammenfassen mit Formel: (Spalte Proj ID Zusammengefasst)=22 (Spalte User)= mrup; gngr; tfue
Diese Werte sollten in eine Extra Tabelle kommen in der nur die Spalte Projekt ID und die Spalte User (mit Semikolon getrennt)zusammengefasst. (siehe Lösung ohne Formel)
Wie mache ich dies mit einer Formel?
Mit Verketten klappt es nicht, da ich ja zuerst nach dem der doppelt vorkommt suchen muss und dann erst die Werte aus der anderen Spalte zusammenfassen muss
Ich hoffe dass ich mein Problem gut erklärt habe und freue mich auf Antworten.
Gruß
Helmut Maier

Bild

Betrifft: AW: Excel Werte zusammenfassen mit Suche
von: Dieter
Geschrieben am: 14.07.2015 11:38:28
Hallo Helmut,
1. nach Spalte C sortieren
2. in neuer Spalte Zeile 8 folgende Formel:
=wenn(C7=C8;verketten(G7;";";G8);G8)
3. nach unten auffüllen
Gruß
Dieter

Bild

Betrifft: AW: Excel Werte zusammenfassen mit Suche
von: SF
Geschrieben am: 14.07.2015 11:44:31
Hola,
siehe auch....
http://www.office-loesung.de/p/viewtopic.php?f=166&t=696335
Gruß,
steve1da

Bild

Betrifft: warum nicht einfach eine PIVOTauswertung?...
von: der neopa C
Geschrieben am: 14.07.2015 11:48:20
Hallo Helmut,
... das hast Du mit wenigen Mausklicks gleich für alle IDs Deine jeweiligen Nutzer zusammengefasst (wenn auch nicht in einer Zelle).
Als eine reine Formellösung folgende Formel z.B. in L4:
=WENNFEHLER(INDEX($G:$G;AGGREGAT(15;6;ZEILE($Z1:$Z399)/($C1:$C399=$I4)/ISTNV(VERGLEICH($G1:$G399;$K4:K4;));1));"") und diese nach rechts ziehend kopieren.
Wenn Du die unbedingt zusammengeführt in einer Zelle haben willst, kannst Du anschließend noch verknüpfen.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Excel Werte zusammenfassen mit Suche"