Probleme mit MAX-Funktion in VBA!

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
MsgBox
Bild

Betrifft: Probleme mit MAX-Funktion in VBA!
von: Msg Box
Geschrieben am: 22.08.2015 14:49:31

Hallo zusammen,
folgendes banales Problem: wir haben eine Tabelle (s. Foto) in welcher wir jeweils die maximale Höhe von Paletten bestimmen sollen, die die gleiche Zahl am Anfang der Positions-ID haben. Hier z.B. bereits 3 verladene Paletten, die alle die Zahl 1 (Positions-Spalte) haben. Wie bekommen wir nun das Maximum aus den 3 Werten der Höhe heraus? Mit "Range" klappt es leider nicht, kann aber auch sein das wir zu doof dafür sind :D
Normalerweise ist die Tabelle gefüllt (40 Zeilen, 5 Spalten) und die max. Höhe soll jeweils aus den gleichen Positionen errechnet werden.
MsgBox."Vielen Dank im Voraus für jegliche Antworten!"
Tabelle: Userbild

Bild

Betrifft: AW: Probleme mit MAX-Funktion in VBA!
von: Daniel
Geschrieben am: 22.08.2015 15:09:56
Hi
wie man das am besten löst, hängt vom genauen Aufbau der Daten ab, dh wenn es immer genau 3 untereinander stehende Zellen sind die zusammen ausgewertet werden müssen, lässt sich das Problem anders lösen, als wenn die Anzahl varrieren kann oder die Liste unsortiert sein kann.
ist die Zeichenfolge, welche die zusammengehörigkeit beschreibt immer eine Ziffer und ist sie immer genau 1 Zeichen lang.
Persönlich würde ich bei grösseren Datenmengen folgendes favorisieren:
1. Trenne in einer Hilfsspalte die Postion auf, so dass die Nummer und der Buchstabe in getrennten Spalten stehen (aus "1A" wird "1" und "A")
2. dann könntest du die Auswertung relativ einfach von Hand mit der Pivottabelle machen.
Gruss Daniel

Bild

Betrifft: AW: Probleme mit MAX-Funktion in VBA!
von: Herbert Grom
Geschrieben am: 22.08.2015 17:54:50
Hi,
mach Dir in Spalte G eine Hilfsspalte und schreibe diese Matrix-Formel {=SUMME((TEIL(0&A2;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&A2;ZEILE($1:$11);1)*1);ZEILE($1:$11);1);ZEILE($1:$11));1)*1)*10^(ZEILE($1:$11)-1))} in G2. Die geschweiften Klammern nicht mit eingeben, sondern mit erzeugen! Anschließend bis zum Ende herunterkopieren.
In H2 setzt Du diese Formel: {=WENNFEHLER(INDEX(G:G;AGGREGAT(15;6;ZEILE(G$2:G12)/ISTNV(VERGLEICH(G$2:G$12;H$1:H1;));ZEILE(G1)));"")} und wieder herunterkopieren.
In I2 kannst Du es dann damit =SUMMEWENN(G:G;H:H;E:E) summieren.
Servus

Bild

Betrifft: AW: Probleme mit MAX-Funktion in VBA!
von: Herbert Grom
Geschrieben am: 22.08.2015 18:14:56
Ich meinte natürlich "mit (SHIFT & STRG & RETURN) erzeugen! ;o)=)

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datei als xlsx speichern"