Einzelne Noten über Zeile abgreifen

Bild

Betrifft: Einzelne Noten über Zeile abgreifen
von: Joachim
Geschrieben am: 08.10.2015 16:34:02

Hallo,
ich suche schon länger nach einer geeigneten Formel, um aus einer Zeile mit x Spalten nur die Werte <>0 abzugreifen, um sie übersichtlich darzustellen.
Etwa so, wenn Noten nur manchmal gemacht werden können.
Name - - - - - 1.10. - - - - - 5.10. - - - - - 13.10. - - - - - 20.10. - - - - - 27.10. - - - - - Erg.1 - - - - - Erg. 2
Franz - - - - - - 2 - - - - - - - 1,5 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - 2 - - - - - - - 1,5
Elke - - - - - - - - - - - - - - - -3 - - - - - - - - - - - - - - - - - - 1 - - - - - - - - - - - - - - - - - 3 - - - - - - - 1
Dieter - - - - - -4 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - 4
Wie müssten die Formeln für Erg.1 und Erg. 2 Lauten. Geht das mit SVerweis?
Vielen Dank im Voraus!
Joachim

Bild

Betrifft: AW: Einzelne Noten über Zeile abgreifen
von: Sepp
Geschrieben am: 08.10.2015 19:36:10
Hallo Joachim,
Tabelle1

 ABCDEFGHIJK
1Name 1.10. 5.10. 13.10. 20.10. 27.10.   Erg.1 Erg.2 Erg.3 Erg.4
2Franz 21,5    21,5  
3Elke  3 1  31  
4Dieter 4     4   
5Test12345 1234
6           

Formeln der Tabelle
ZelleFormel
H2{=WENNFEHLER(INDEX($B2:$F2;;KKLEINSTE(WENN($B2:$F2<>"";SPALTE($A$1:$E$1)); SPALTE(A$1))); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Sepp


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Einzelne Noten über Zeile abgreifen"