Microsoft Excel

Herbers Excel/VBA-Archiv

Suchen und Löschen


Betrifft: Suchen und Löschen von: Julian
Geschrieben am: 02.10.2019 12:02:22

Hallo Zusammen,

folgendes Problem. Ich besitzte diese Reihenfolge
-QM1
-QM1MM1
-QM1MM2
-QM1MM3
-QM1MM4
-QM2
-QM2MM1
-BZ1
-BZ1.1
....

ich möchte aber das -QM1...-QM2--QMn entfernen lassen da sie ungebraucht sind.

Gibt es da ein einfaches Makro?
Dachte an eine For schleife

Gruß
Julian

  

Betrifft: doppelt! owt von: Torsten
Geschrieben am: 02.10.2019 12:06:11




  

Betrifft: nix Makro: Suchen + Ersetzen von: WF
Geschrieben am: 02.10.2019 12:24:21

Hi,

suchen nach QM?
ersetzen durch nichts

WF


  

Betrifft: AW: nachgefragt ... von: neopa C
Geschrieben am: 02.10.2019 13:04:58

Hallo Julian,

... steht -QMn immer nur mit einer folgenden Zahl? Kann die Zahl n nie größer werden als 9? Wenn ja nutze den Vorschlag von WF. Wenn nein, bedarf es weiterer Ausführungen Deinerseits, so zumindest ob -QMn immer am Anfang steht?

Gruß Werner
.. , - ...


  

Betrifft: AW: nachgefragt ... von: Julian
Geschrieben am: 02.10.2019 13:19:33

Hallo Werner,

Es geht bis maximal 20 hoch also -QM1....-QM20
Die Spalte mit dem -QM1 soll gelöscht werden. Habe mit dem Makroaufzeichner was rausgefunden.
Jedoch wird wenn eine nicht vorhandene Bezeichnung gesucht wird nicht durchgeführt.


   Worksheets("Gesamtinfo").Columns("A:A").EntireColumn.Select
    Selection.Find(What:="-QM1", After:=ActiveCell, LookIn:=xlFormulas, _
        LookAt:=xlPart, SearchOrder:=xlByRows, SearchDirection:=xlNext, _
        MatchCase:=False, SearchFormat:=False).Activate
    ActiveCell.Rows("1:1").EntireRow.Select
    Selection.Delete Shift:=xlUp
Suche ich z.Bsp. Nach -QM3 gibt es eine Debugghinweis.
Die Funktion ist leider mitten in einem Größeren Makro beinhaltet

Gruß

Julian


  

Betrifft: AW: VBA-Lösung gesucht, therad offen owT von: neopa C
Geschrieben am: 02.10.2019 13:31:09

Gruß Werner
.. , - ...


  

Betrifft: AW: nachgefragt ... von: Daniel
Geschrieben am: 02.10.2019 14:10:26

Hi
wenn man davon ausgehen kann, dass der gesuchte wert auch mal nicht vorkommt, dann geht man in VBA so vor:

1. man schreibt das Suchergebnis in eine RANGE-Variable
dann bekommt man beim nicht-finden keinen Fehler, sondern die Variable wird auf Nothing gesetzt
2. man prüft vor der weiteren Ausführung, ob die Variable befüllt wurde oder ob sie leer ist

dim rngFIND as range
set rngFIND =  Worksheets("Gesamtinfo").Columns("A:A").Find(what:="-QM1", ....)
if Not rngFIND is nothing then rngFIND.EntireRow.Delete
Gruß Daniel


  

Betrifft: AW: Suchen und Löschen von: Daniel
Geschrieben am: 02.10.2019 13:41:19

Hi
als VBA beispielsweise so, wenn die Texte feste Werte sind und keine Formeln:

Columns(1).Replace "-QM*", True, xlwhole
columns(1).SpecialCells(xlcelltypeconstants, 4).entireRow.Delete
Gruß Daniel


  

Betrifft: AW: Suchen und Löschen von: Julian
Geschrieben am: 02.10.2019 13:45:32

Es darf nur das -QM1-QMn entfernt werden.
-QM1MM1 etc muss ich behalten


  

Betrifft: AW: Suchen und Löschen von: Daniel
Geschrieben am: 02.10.2019 14:01:27

dann ersetze nacheinander "-QM?" und "-QM??" durch True und führe dann das Löschen der Zeilen durch.
Gruß Daniel


  

Betrifft: AW: Suchen und Löschen von: Günther
Geschrieben am: 02.10.2019 14:00:04

Wenn nicht noch mehr ungenannte bzw. ungenügend beschriebene Bedingungen dazu kommen, dann lässt sich das gut mit Power Query lösen.

Gruß
Günther


  

Betrifft: AW: Suchen und Löschen von: Daniel
Geschrieben am: 02.10.2019 14:02:42

danke für den informativen hinweis.
Gruß Daniel


  

Betrifft: AW: Suchen und Löschen von: Piet
Geschrieben am: 04.10.2019 16:08:14

Hallo Julian

ich weisse höflich darauf hin das die Lösung von Daniel bereits in diesem Thread gesagt wurde:
Columns(1).Replace "-QM*", True, xlwhole
columns(1).SpecialCells(xlcelltypeconstants, 4).entireRow.Delete

Da muss doch nur der Text "-QM*" gegen "-QM1-QMn" getauscht werden.

mfg Piet


  

Betrifft: AW: Suchen und Löschen von: Daniel
Geschrieben am: 04.10.2019 16:23:57

"n" soll hier wohl die Zahlen 1-20 darstellen.
Gruß Daniel


  

Betrifft: warum denn nicht mit Formeln & dann Filtern ... von: Matthias L
Geschrieben am: 04.10.2019 23:58:16

Hi

Tabelle1

 AB
1ORGFilter
2-QM1 
3-QM1MM1-QM1MM1
4-QM1MM2-QM1MM2
5-QM1MM3-QM1MM3
6-QM1MM4-QM1MM4
7-QM2 
8-QM2MM1-QM2MM1
9-BZ1-BZ1
10-BZ1.1-BZ1.1
11-QM14 
12-QM20 

Formeln der Tabelle
ZelleFormel
B2=WENN(UND(LINKS(A2;3)="-QM";LÄNGE(A2)<6);"";A2)
B3=WENN(UND(LINKS(A3;3)="-QM";LÄNGE(A3)<6);"";A3)
B4=WENN(UND(LINKS(A4;3)="-QM";LÄNGE(A4)<6);"";A4)
B5=WENN(UND(LINKS(A5;3)="-QM";LÄNGE(A5)<6);"";A5)
B6=WENN(UND(LINKS(A6;3)="-QM";LÄNGE(A6)<6);"";A6)
B7=WENN(UND(LINKS(A7;3)="-QM";LÄNGE(A7)<6);"";A7)
B8=WENN(UND(LINKS(A8;3)="-QM";LÄNGE(A8)<6);"";A8)
B9=WENN(UND(LINKS(A9;3)="-QM";LÄNGE(A9)<6);"";A9)
B10=WENN(UND(LINKS(A10;3)="-QM";LÄNGE(A10)<6);"";A10)
B11=WENN(UND(LINKS(A11;3)="-QM";LÄNGE(A11)<6);"";A11)
B12=WENN(UND(LINKS(A12;3)="-QM";LÄNGE(A12)<6);"";A12)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Jetzt filterst Du nach Spalte("B") und deaktivierst "Leere".
Dann bleibt das übrig.

Tabelle1

 AB
1ORGFilter
3-QM1MM1-QM1MM1
4-QM1MM2-QM1MM2
5-QM1MM3-QM1MM3
6-QM1MM4-QM1MM4
8-QM2MM1-QM2MM1
9-BZ1-BZ1
10-BZ1.1-BZ1.1


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Matthias


Beiträge aus dem Excel-Forum zum Thema "Suchen und Löschen"