Microsoft Excel

Herbers Excel/VBA-Archiv

Zahl suchen und bestimmte Zellen der Zeile einfüge


Betrifft: Zahl suchen und bestimmte Zellen der Zeile einfüge von: Achim Brinckmann
Geschrieben am: 04.08.2018 18:28:59

Hi,

ich bin nicht so fit in Excel und möchte aber eine Aufgabe die eher zur Datenbank passt umsetzen.

Im Register 1 möchte ich die Stammdaten anlegen.
A2-A100 wird eine fortlaufende Zahl (1-99) eingegeben. B2;C2;D2 bis B100;... enthält nur Textbausteine.
Jetzt möchte im im 2. Register z. B. in A2 eine Zahl eingeben die er dann im 1. Register von A2-A100 sucht und dann die entsprechende Zeile B2;... bis B100;... daneben einfügt. Also die ganze Zeile außer der Anfangszahl aus A2.

Hoffe ich habe mich verständlich ausgedrückt und lacht mich nicht aus weil es für Euch so einfach ist ^^
Für mich momentan unlösbar.
Funktion Zeile () habe ich mir angesehen, aber da komme ich nicht mit klar und brauche sicher noch weitere Funktionen die dort integriert werden müssen.

  

Betrifft: AW: Zahl suchen und bestimmte Zellen der Zeile einfüge von: Hajo_Zi
Geschrieben am: 04.08.2018 18:31:11

benutze Sverweis(9
=Sverweis(A2;Tabelle1!A:Z;Spalte();0)

GrußformelHomepage


Beiträge von Werner, Luc, robert, J.O.Maximo und folgende lese ich nicht.


  

Betrifft: AW: Zahl suchen und bestimmte Zellen der Zeile einfüge von: Achim Brinckmann
Geschrieben am: 04.08.2018 18:31:29





  

Betrifft: AW: Zahl suchen und bestimmte Zellen der Zeile einfüge von: Hajo_Zi
Geschrieben am: 04.08.2018 18:34:18

Hochgeladene Bilder können zwar als solche in Excel importiert werden, sind jedoch bei der Lösung von Problemen nicht sehr hilfreich, da man die eigentlichen Daten nicht ohne große und zeitraubende Umwege direkt in die Tabelle übertragen kann.
Schau mal hier
Eine hochgeladene Arbeitsmappe erhöht die Wahrscheinlichkeit, dass Du eine Lösung für Dein Problem erhältst.
Erstelle folglich bitte eine Demomappe, aus der deine Aufgabenstellung klar erkennbar ist und lade diese hoch.
Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, solltest du diese Daten anonymisieren bzw. pseudonymisieren.
Falls Du den Download des Forums nicht benutzen möchtest beachte bitte: von unsicheren Servern file-upload lade ich keine Datei herunter (lt. Einschätzung meines Virenprogramms)


Es wurde keine Datei hochgeladen, da Du die Lösung selber an Deine Bedingungen anpassen wolltest.
Also mache es auch.


Gruß Hajo


  

Betrifft: AW: Zahl suchen und bestimmte Zellen der Zeile einfüge von: Achim Brinckmann
Geschrieben am: 04.08.2018 18:43:53

https://www.herber.de/bbs/user/123135.xlsx

liegt die Musterdatei. Ist ja in den ersten Zügen^^

Wie gesagt möchte ich in dem Register Stundenzettel nur noch die Nummer eintragen die durchgeführt werden soll und dann werden die restlichen Felder in der Zeile automatisch gefüllt.

Möchte das nicht unbedingt selber machen, aber versuchen zu verstehen.

Danke für Deine Hilfe


  

Betrifft: AW: Zahl suchen und bestimmte Zellen der Zeile einfüge von: Hajo_Zi
Geschrieben am: 04.08.2018 18:48:00

Du solltest mal überlegen ob Excel das richtige Programm für Dich ist, wenn Du "Tabelle1" nicht durch die aktuellen Tabellennamen ersetzen kannst.
Ich bin dann raus, da ich nicht für den Papierkorb arbeite.

Gruß Hajo


  

Betrifft: AW: hierzu (m)eine Anmerkung ... von: neopa C
Geschrieben am: 04.08.2018 19:23:15

Hallo Hajo,

... Achim hat sich sowohl durch seine Level-Angabe als auch durch seine Fragestellung eindeutig als Excel Einsteiger ausgewiesen. Jeder fängt mal als solcher an und deshalb gehört Deine letzte Anmerkung wirklich in den "Papierkorb".

Gruß Werner
.. , - ...


  

Betrifft: AW: hierzu (m)eine Anmerkung ... von: Achim Brinckmann
Geschrieben am: 05.08.2018 17:56:05

Danke für die Hilfe.
Wenigstens strafst Du mich nicht gleich ab :-)
Damit komme ich klar und weiter.

Habe =SVERWEIS(A2;Stammdaten!A:Z;SPALTE();0) nach B2, C2 und D2 kopiert. Ging auch.
Deine Formel teste ich auch noch und lese mich dann ein um das einigermaßen zu verstehen^^

Klasse von Dir


  

Betrifft: AW: dazu ergänzend angemerkt ... von: neopa C
Geschrieben am: 05.08.2018 19:32:18

Hallo Achim,

... die erwähnte Formel musst Du jeweils einzeln in die entsprechende Ergebniszellen der Nachbarspalten ein kopieren.

Wenn Du jedoch meine Formel in B2 einkopierst, kannst Du diese dann ziehend nicht nur nach unten sondern auch nach rechts kopieren. Dazu musst Du nur mit der Maus über die rechte untere Zellecke "streichen" bis das kleine Cursorfadenkreuz erscheint. Dann kannst Du bei gedrückter linker Maustaste das "ziehende kopieren" realisieren.

Die korrekte Ergebnisermittlung wird hier dadurch gewährleistet, dass die Zellbezüge in der Formel mittels "$" "verabsolutiert" wurden. Mehr dazu sieh mal hier: https://www.online-excel.de/excel/singsel.php?f=56.

In Deinem Beispiel ist der Vorteil zwar vernachlässigbar aber in anderen Fällen kann Dir dies Wissen künftig viel Zeit ersparen.

Gruß Werner
.. , - ...


  

Betrifft: AW: mit richtigem Einsatz von SVERWEIS() ... von: neopa C
Geschrieben am: 04.08.2018 19:15:17

Hallo Achim,

... ist das von Dir angestrebte leicht zu erreichen.

Kopiere in Stundenzettel!B2 folgende Formel:

=WENN(A2="";"";SVERWEIS($A2;Stammdaten!$A:$D;SPALTE();0))

und anschließend kopiere diese nach C2 und D2 und danach diese ziehend nach unten.

Mehr zu SVERWEIS() sieh mal hier: https://www.online-excel.de/excel/singsel.php?f=9

Gruß Werner
.. , - ...


Beiträge aus dem Excel-Forum zum Thema "Zahl suchen und bestimmte Zellen der Zeile einfüge"