Microsoft Excel

Herbers Excel/VBA-Archiv

Dienstplan! Richtwerte aus anderer Datei übernehme

Betrifft: Dienstplan! Richtwerte aus anderer Datei übernehme von: Simon
Geschrieben am: 07.09.2004 23:10:13

Hallo Leute,

ich bin gerade bei der Erstellung eines Dienstplanes.
Zeilen nach unten beschreiben die Mitarbeiter / Spalten nach rechts die Tage eines jeden Monats (1 - 30). In das so entstandenen Raster werden pro Tag und Mitarbeiter, Buchstaben als Schichtbeschreibung eingetragen.
Zum Beispiel "F" für Frühschicht = 8 Arbeitsstunden und "S" für Spätschicht = 8,5 Arbeitsstunden.

Nun soll am Ende des Planes eine IST Spalte ausweisen, wieviele Stunden ein jeder Mitarbeiter gearbeitet hat. Sprich nur durch das Eintragen der Buchstaben deren Werte er sich aus einer anderen Datei oder Arbeitsmappe holt soll die Summe in der IST Spalte ermittelt werden.

Beispiele
F = 8 Stunden
S = 8,5 Stunden
N = 8 Stunden

usw...

dringend Hilfe benötigt.

Danke Simon

  


Betrifft: AW: Dienstplan! Richtwerte aus anderer Datei übernehme von: P@ulchen
Geschrieben am: 07.09.2004 23:31:28

Hi Simon,

ich bin zwar kein Formelexperte, aber so sollte es wohl gehen (Schichten werden in Spalte C bis AG eingetragen):

=ZÄHLENWENN(C3:AG3;"F")*8+ZÄHLENWENN(C3:AG3;"N")*8+ZÄHLENWENN(C3:AG3;"S")*8,5



Gruß aus Leipzig
P@ulchen

Das Forum lebt auch von den Rückmeldungen !


 

Beiträge aus den Excel-Beispielen zum Thema "Dienstplan! Richtwerte aus anderer Datei übernehme"