Leere Zeilen löschen/Problem



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Leere Zeilen löschen/Problem
von: Ralf F.
Geschrieben am: 05.06.2002 - 18:06:36

Hallo Experten, ich habe folgendes Problem.
Ich habe mir ein Makro aufgezeichnet, markieren, kopieren
Werte einfügen. Das klappt auch, jetzt sind aber "leere" Zeilen
dabei, die müßen aber weg, damit alle Daten untereinander stehen.
Habe dafür bei Herbers folgendes gefunden :

Sub LeerZeilenLöschen()
Dim i%, Alle%
Application.ScreenUpdating = False
Alle = Cells.Find("*", [A1], , , xlByRows, xlPrevious).Row
For i = Alle To 1 Step -1
Do While Application.CountA(Rows(i)) = False
Rows(i).EntireRow.Delete
Loop
Next i
End Sub

Dieses ist echt gut, wenn ich manuell Daten eingebe, löscht er astrein.
In den kopierten Daten sind folgende Formeln :
=WENN($D6>0;D6-$H6;"")

liegt es daran ??
Habt ihr eine Ahnung wie ich das Lösen kann`??
Wenn ich in den leeren Zellen so mal alle lösche und danach den Sub laufen lasse, geht es.
Kann ich das anders lösen mit den kopieren der Daten ?

Gruß, Ralf F.



nach oben   nach unten

Re: Leere Zeilen löschen/Problem
von: WernerB.
Geschrieben am: 05.06.2002 - 19:04:05

Hallo Ralf,

teste doch mal dieses Makro:

Viel Erfolg wünscht
WernerB.

nach oben   nach unten

Re: Leere Zeilen löschen/Problem
von: Ralf F.
Geschrieben am: 05.06.2002 - 19:38:25

Danke Werner, genau das ist es.

Gruß, Ralf


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Leere Zeilen löschen/Problem"