Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Feld leer

Betrifft: Wenn Feld leer von: Werner
Geschrieben am: 08.11.2012 21:30:57

Hallo Excel-Freunde,

Habe in einer Zelle folgende Formel stehen:

=WENN(ODER(UT22="U";UT$5="Feiertag");WENN(VT22=0;"";SVERWEIS(TU22;PERSONAL!$1:65556;20;FALSCH)); WENN(UT22="";0;WENN(UU23>UW22;UU23-UY22+UX87;WENN(UU23>UW23;UU23-UY23+UX87;WENN(UU23>UX22; UU23-UZ22+UX87;UU23-UU22+UX87)))))

Nun soll vor berechnung der Formel eine Abfrage der Zelle UT22 in etwa so erfolgen:
wenn Zelle UT22 ist leer, dann soll keine berechnung statt finden, ansonsten soll ganz normal die oben genannte Formel ausgeführt werden.

Gruß
Werner

  

Betrifft: AW: Wenn Feld leer von: Hajo_Zi
Geschrieben am: 08.11.2012 21:37:13

Hallo Werner,

=wenn(Ut22="";"";DeineFormel)


GrußformelHomepage


  

Betrifft: AW: Wenn Feld leer von: silex1
Geschrieben am: 08.11.2012 21:40:35

Hallo,

und dafür kannst Du dann
WENN(UT22="";0
aus der Formel heraus nehmen.

VG, Rene