Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert mehrere Spalten und mehrere Kriterien

Betrifft: Mittelwert mehrere Spalten und mehrere Kriterien von: Helmuth
Geschrieben am: 12.07.2015 22:55:26

Hallo,
ich hoffe ihr könnt mir da weiterhelfen.

Meine Absicht ist es, in der angeführten Tabelle in der Spalte H2 im Falle der Kombination Auto = 1 (Spalte A)und Motor = 1 (Spalte B) den Mittelwert der entsprechenden Spalten C D und E (im beiliegenden Beispiel den Mittelwert aus 2, 1, 3, 2, 2, 2, 1, 3, 1) zu berechnen. Das Ergebnis in diesem Falle wäre 1,88.

Mit der Formel MITTELWERTWENNS komme ich da nicht weiter, da der Mittelwert_Bereich C2:E8 angeblich nicht zulässig ist.

Danke im voraus für eure Unterstützung.

Helmuth


  

Betrifft: AW: Mittelwert mehrere Spalten und mehrere Kriterien von: Sepp
Geschrieben am: 12.07.2015 23:06:26

Hallo Helmuth,

Tabelle3

 ABCDEFGHI
1AutoMotorQualitätVerbrauchPreis    
211213  1,88888889 
321122    
413331    
511222    
622221    
723113    
811131    
9         

Formeln der Tabelle
ZelleFormel
H2{=MITTELWERT(WENN((A2:A8=1)*(B2:B8=1); C2:E8))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Ein Bildchen anstelle einer Tabelle hochzuladen, scheint gerade groß in Mode zu sein! Kann deine Excelversion mit Bildern rechnen?

Gruß Sepp



  

Betrifft: AW: Mittelwert mehrere Spalten und mehrere Kriterien von: Helmuth
Geschrieben am: 13.07.2015 12:40:44

Hallo Sepp,

tausend Dank!

Hast mir sehr, sehr geholfen!

Das mit der Tabelle anstatt des Bildchen werde ich in Zukunft selbstverständlich berücksichtigen.

Gruß Helmuth


 

Beiträge aus den Excel-Beispielen zum Thema "Mittelwert mehrere Spalten und mehrere Kriterien"