Excel Tabellendarstellung

Bild

Betrifft: Excel Tabellendarstellung
von: Bastian
Geschrieben am: 30.07.2015 16:17:10

Hallo,
ich benötige eure Hilfe bei folgender Aufgabenstellung:
Ich habe eine Tabelle mit einem Produktionsplan. In diesem Plan werden Materialien und deren Anzahl aufgeführt.
Beispiel Produktionsplan:
Materialnummer Anzahl
Matnr. 1 5
Matnr. 2 10
Matnr. 3 7
Matnr. 4 15
Matnr. 5 13
Summe 50
Dieser Plan soll nun in Einzelpositionen der Reihe nach aufgelöst werden.
Beispiel Produktionsplan Einzelpositionen:
Werkzeugnr. Materialnummeer
1 Matnr. 1
2 Matnr. 1
3 Matnr. 1
4 Matnr. 1
5 Matnr. 1
6 Matnr. 2
7 Matnr. 2
8 Matnr. 2
9 Matnr. 2
10 Matnr. 2
11 Matnr. 2
12 Matnr. 2
... ... ...
50 Matnr. 5
Leider finde ich keine Funktion die es mir ermöglicht den manuellen Aufwand zu reduzieren.
Ich verwende Office 365.
https://www.herber.de/bbs/user/99196.xlsx
Bin für jeden Hinweis dankbar.
Gruß & Dank
Bastian

Bild

Betrifft: AW: Excel Tabellendarstellung
von: Rudi Maintaire
Geschrieben am: 30.07.2015 16:32:35
Hallo,

CDEFGH
6Produktionsplan  Liste  
7      
8MaterialnummeerAnzahl Werkzeugnr.MaterialnummerAnzahl
9Matnr. 15 1Matnr. 11
10Matnr. 210 2Matnr. 11
11Matnr. 37 3Matnr. 11
12Matnr. 415 4Matnr. 11
13Matnr. 513 5Matnr. 11
14Summe50 6Matnr. 21
15   7Matnr. 21
16   8Matnr. 21
17   9Matnr. 21

ZelleFormel
G9=C9
F10=WENN(G10<>"";F9+1;"")
G10=WENN(ZEILE(A2)>SUMME($D$9:$D$13);"";WENN(ZÄHLENWENN($G$9:G9;G9)<SVERWEIS(G9;$C$9:$D$13;2;);G9;INDEX($C$9:$C$13;VERGLEICH(G9;$C$9:$C$13;)+1)))
F11=WENN(G11<>"";F10+1;"")
G11=WENN(ZEILE(A3)>SUMME($D$9:$D$13);"";WENN(ZÄHLENWENN($G$9:G10;G10)<SVERWEIS(G10;$C$9:$D$13;2;);G10;INDEX($C$9:$C$13;VERGLEICH(G10;$C$9:$C$13;)+1)))

und runter kopieren bis der Arzt kommt.
Gruß
Rudi

 Bild

Beiträge aus den Excel-Beispielen zum Thema "VBA-aufsteigend nach Kosten sortieren"