Microsoft Excel

Herbers Excel/VBA-Archiv

Indirekt Formel mit dynamischer Zelle

Betrifft: Indirekt Formel mit dynamischer Zelle von: Stefan
Geschrieben am: 26.10.2020 18:48:54

Hallo zusammen,

ich würde gerne eine Indirect funktion mit einer Index Funktion verknüpfen.

=INDEX(Sheet2!A4:F7;MATCH(A4;Sheet2!A4:A7;0);MATCH(A2;Sheet2!A4:F4;0))
=INDIRECT("'"&A8&"'!B5")

In dem Fall soll die Zelle B5 aus der indirect Funktion gegen die Zelle welche das Ergebnis aus der Index Funktion ist getauscht werden.
Heisst anstelle von B5 soll die Index Funktion eingebaut werden in die Indirect Formel.

ich stehe irgendwie auf dem Schlauch.

Kann mir bitte jemand helfen?

Betrifft: AW: Indirekt Formel mit dynamischer Zelle
von: SF
Geschrieben am: 26.10.2020 19:04:41

Hola,

und was ist das Ergebnis der Index Formel genau?

Gruß,
steve1da

Betrifft: AW: Indirekt Formel mit dynamischer Zelle
von: Stefan
Geschrieben am: 26.10.2020 19:16:20

Die Index Formel sucht im Sheet 2 nach dem Datum welches in A2 steht und A4 sucht nach dem Wort "Summe". Anschließend wird der wert der entsprechenden Zelle ausgegeben.

z.B.: in Sheet 1 A2 steht 03.01.2020
in Sheet 1 A4 steht das Wort "Summe"

In Sheet 2 wird in der Spalte A nach dem Wort "Summe" gesucht (z.B in A6)
In Sheet 2 wird in Reihe 4 nach dem Datum 03.01.2020 gesucht (steht z.B in C4)
Ausgabe Wert aus der Schnittmenge beider Funktionen hier C6 (z.B. 20000)

Ich hoffe es hilft.

Danke

Betrifft: AW: warum dazu INDIREKT(), und INDEX() ? ...
von: neopa C
Geschrieben am: 27.10.2020 09:02:05

Hallo Stefan,

... ausreichend wäre (im deutsprachige) Excel folgende einfache Formel:

=SVERWEIS(A4;sheet2!A:Z;VERGLEICH(A2;sheet2!4:4;0);0)

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Indirekt Formel mit dynamischer Zelle"