Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Formatierung neben Datum | Herbers Excel-Forum


Betrifft: Bedingte Formatierung neben Datum von: Chris
Geschrieben am: 18.01.2012 16:05:18

Hallo zusammen,

vielleicht könnt ihr mir weiterhelfen:
In der Spalte C ab Zelle C6 habe ich Daten im Format 01.01.2012 stehen.
In der Spalte B ab Zelle B6 habe ich jeweils 7 Zellen verbunden, um so die passende Kalenderwoche darzustellen.
Nun möchte ich gerne diese verbundene Zelle rot ausfüllen, sofern in einer der 7 Zellen rechts davon das aktuelle Datum steht. Ideen?

Viele Grüße
Chris

  

Betrifft: Ja! Gruß owT von: Luc:-?
Geschrieben am: 18.01.2012 16:09:05

:-?


  

Betrifft: Ansatz einer Lösung von: Frank Hering
Geschrieben am: 18.01.2012 16:21:06

Hi,

Könntest in die Spalte A folgende Formel eingeben, wenn du noch platz hast oder sonst eine neue Spalte nehmen

=WENN(C6>(HEUTE()-WOCHENTAG(HEUTE()));1;0)

Und dann eine Bedingte Formatierung mit dieser Formel und deinen Farbwünschen

=WENN($A7=1;WAHR)

Dann müßte es klappen



Gruß Frank


  

Betrifft: AW: Ansatz einer Lösung von: Frank Hering
Geschrieben am: 18.01.2012 16:24:42

Sorry erste Formel klappt so net. Du brauchst diese.

=WENN(C6>(HEUTE()-WOCHENTAG(HEUTE()));WENN(C6<(HEUTE()+WOCHENTAG(HEUTE()));1;0);0)


  

Betrifft: AW: Bedingte Formatierung neben Datum von: Josef Ehrensberger
Geschrieben am: 18.01.2012 16:14:45


Hallo Chris,

mit verbundenen Zellen geht das nicht, und die braucht an normalerweise auch nicht, die machen nur Probleme.

Tabelle1

 ABCD
5    
6  So     01.01.2012 
7  Mo     02.01.2012 
8  Di      03.01.2012 
9  Mi      04.01.2012 
10  Do     05.01.2012 
11  Fr      06.01.2012 
12  Sa     07.01.2012 
13  So     08.01.2012 
14  Mo     09.01.2012 
15  Di      10.01.2012 
16  Mi      11.01.2012 
17  Do     12.01.2012 
18  Fr      13.01.2012 
19  Sa     14.01.2012 
20  So     15.01.2012 
21  Mo     16.01.2012 
22  Di      17.01.2012 
23  Mi      18.01.2012 
24  Do     19.01.2012 
25  Fr      20.01.2012 
26  Sa     21.01.2012 
27  So     22.01.2012 
28  Mo     23.01.2012 
29  Di      24.01.2012 
30  Mi      25.01.2012 
31  Do     26.01.2012 
32    

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
B61. / Formel ist =KÜRZEN((C6-DATUM(JAHR(C6+3-REST(C6-2;7));1;REST(C6-2;7)-9))/7)=KÜRZEN((HEUTE()-DATUM(JAHR(HEUTE()+3-REST(HEUTE()-2;7));1;REST(HEUTE()-2;7)-9))/7)Abc
B62. / Formel ist =REST(KÜRZEN((C6-DATUM(JAHR(C6+3-REST(C6-2;7));1;REST(C6-2;7)-9))/7);2)Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung neben Datum"