Microsoft Excel

Herbers Excel/VBA-Archiv

SummeWenn - Formel funktioniert nicht

Betrifft: SummeWenn - Formel funktioniert nicht von: Andreas
Geschrieben am: 31.07.2014 13:06:18

Hallo Excelprofis,

habe mal wieder ein Problemchen.

Mit folgender Formel möchte ich die Summe aller Werte im Bereich D3 bis E28 berechnen, bei denen in Spalte A3:A28 der Wert "Mo" steht.

Das Problem ist aber, dass in Spalte A nur eine Verknüpfung zu Spalte B steht. In Spalte B stehen Datumswerte (Format TT.MM) und damit in A auch ein Datumswert (Format MM).
Meine Formel funktioniert wohl nicht, weil in A ein Datumswert steht.

=SUMMEWENN(A3:A28;"Mo";D3:E28)

Kann mir bitte Jemand helfen.

mfg, Andreas

  

Betrifft: AW: SummeWenn - Formel funktioniert nicht von: Arthur
Geschrieben am: 31.07.2014 13:14:08

Hallo Andreas.

Per Summenformelklappt es vielleicht nicht, weil diese keine Bereiche/ eingebauten Formeln mag. So kann es dennoch funktionieren:

=SUMMENPRODUKT((WOCHENTAG(A2:A35;2)=1)*(D2:D35+E2:E35))


Gruß, Arthur


  

Betrifft: Vielen Dank für die Hilfe, funktioniert! owT von: Andreas
Geschrieben am: 31.07.2014 13:22:08

.


  

Betrifft: hier wäre es auch möglich ... von: neopa C (paneo)
Geschrieben am: 31.07.2014 15:32:37

Hallo Arthur,

... den Bereich direkt auswerten zu lassen: =SUMMENPRODUKT((WOCHENTAG(A2:A35;2)=1)*(D2:E35))


Gruß Werner
.. , - ...


  

Betrifft: AW: SummeWenn - Formel funktioniert nicht von: MiGre
Geschrieben am: 31.07.2014 13:44:53

Hallo Andreas!

Hier ein Thread der Dein Problem, denke ich, bereits löst:

https://www.herber.de/forum/archiv/636to640/638185_summewenn_mehrere_bereiche.html

Hoffe es klappt, liebe Grüße
MiGre


  

Betrifft: Vielen Dank Euch für die Hilfe! Schönes WE! owT von: Andreas
Geschrieben am: 01.08.2014 18:56:12

.


 

Beiträge aus den Excel-Beispielen zum Thema "SummeWenn - Formel funktioniert nicht"