Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

summenprodukt wenn nicht wert

summenprodukt wenn nicht wert
01.07.2017 21:46:55
hans
Hallo liebe Excel-Profis,
ich habe ein wirklich kleines Problem.
Hier die Formel:
=SUMMENPRODUKT(--($E$2:$E$10000=J$8);--$B$2:$B$10000)
-SUMMENPRODUKT(--($E$2:$E$10000=J$8);--($F$2:$F$10000J$8);--($F$2:$F$10000"1900/01");--$B$2:$B$10000)
+SUMMENPRODUKT(--($E$2:$E$10000J$8);--($F$2:$F$10000=J$8);--$B$2:$B$10000)
Das Anliegen:
Die Formel funktioniert grundsätzlich. Allerdings gibt es in der Spalte mit den zu addierenden Werten $B$2:$B$10000 Felder, in denen #WERT! drin steht.
Wie kann/muss ich die Formel anpassen, damit die Zeilen, in denen in der Spalte B #WERT! steht einfach nicht berücksichtigt werden?
Vielen Dank und schönes WE

17
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: summenprodukt wenn nicht wert
02.07.2017 00:36:59
SF
Hola,
indem du #WERT mit Wennfehler() gar nicht erste entstehen lässt.
Gruß,
steve1da
AW: summenprodukt wenn nicht wert
02.07.2017 00:40:42
Luschi
Hallo Hans,
die Formel SUMMENPRODUKT(...) mag keine Fehlerwerte in den Spalten.
Da ja in 'B2:B10000' Formeln stehen, woher sollen sonst die Fehlerwerte kommen, ändere die Formeln wie folgt: =WENNFEHLER(Formel;0) oder Du schreibst in einer gesonderten Spalte =WENNFEHLER(B2;0) usw.
und verwendest diese neue Spalte statt Spalte 'B'.
Gruß von Luschi
aus klein-Paris
AW: summenprodukt wenn nicht wert
02.07.2017 01:05:39
Mesut
Danke für die Rückmeldungen.
Die Inhalte der Spalte B kommen aus einem automatischen Import und sind feste Werte - keine Formeln.
Ich habe keine Möglichkeit die vorangegangenen Formeln anzupassen. Den fehlerhaften Datenimport darf ich auch nicht (manuell) korrigieren.
In Spalte B steht halt ab und zu als Text #WERT! drin und diese Zellen stören die Formel. Deswegen die Frage, wie ich die summenprodukt Formel anpassen kann, damit sie trotzdem funktioniert.
Anzeige
AW: summenprodukt wenn nicht wert
02.07.2017 02:06:39
Werner
Hallo Mesut,
hast du den zweiten Teil der Antwort von Luschi überlesen?
oder Du schreibst in einer gesonderten Spalte =WENNFEHLER(B2;0) usw.
und verwendest diese neue Spalte statt Spalte 'B'.

Gruß Werner
AW: summenprodukt wenn nicht wert
02.07.2017 07:41:03
Mesut
guten Morgen Werner,
Ich brauche eine (1) funktionierende Formel, die ohne irgendwelche Krücken oder Hilfsspalten funktioniert.
Ich musste die Formel bereits in der Vergangenheit anpassen und um --() erweitern, damit ich in den Feldern enthaltenen Text rausfiltern kann. Nur bei dem Text "#WERT!" Funktioniert es nicht...
nicht SUMMENPRODUKT sondern SUMME(WENN
02.07.2017 07:12:43
WF
Hi,
statt:
=SUMMENPRODUKT(1*($E$2:$E$10000=J$8);1*$B$2:$B$10000)
nimmst Du die Arrayformel:
=SUMME(WENN($E$2:$E$10000=J$8;1*$B$2:$B$10000))
WF
Anzeige
AW: nicht SUMMENPRODUKT sondern SUMME(WENN
02.07.2017 08:32:02
hans
Moin WF,
für den ersten Teil der Formel funktioniert es. Aber die restliche Formel funktioniert nicht und ergibt ebenfalls den Fehler #WERT.
AW: nicht SUMMENPRODUKT sondern SUMME(WENN
02.07.2017 08:34:02
hans
Moin WF,
für den ersten Teil der Formel funktioniert es. Die zwei weiteren Teile der Formel funktionieren leider nicht und geben den Fehler #WERT! zurück.
dann lad ne Datei hoch
02.07.2017 08:53:09
WF
das nachzubauen hat keiner Lust.
WF
AW: dann lad ne Datei hoch
02.07.2017 11:06:41
hans
moin WF,
anbei die Datei.
https://www.herber.de/bbs/user/114635.xlsx
In der Übersicht auf der rechten Seite sieht man die Werte, die ohne Fehlermeldung erscheinen sollten. Links daneben die Übersicht inkl. Formel (und Fehlermeldung).
Danke und schönen Sonntag
Anzeige
kein Problem mit meinem obigen Strickmuster
02.07.2017 12:08:48
WF
Hi,
in die Zelle J4 folgende Arrayformel:
{=SUMME(WENN($E$2:$E$10000=J$1;1*$A$2:$A$10000))
-SUMME(WENN($E$2:$E$10000=J$1;WENN($F$2:$F$10000J$1;WENN($F$2:$F$10000"1900/01";1*$A$2:$A$10000))))
+SUMME(WENN($E$2:$E$10000J$1;WENN($F$2:$F$10000=J$1;1*$A$2:$A$10000)))}
Salut WF
AW: kein Problem mit meinem obigen Strickmuster
02.07.2017 12:20:20
Daniel
Hi WF
teste mal mit der konstellation:
E2=J2 und A2 mit Fehlerwert.
Gruß Daniel
AW: korrektur: E2=J1
02.07.2017 12:21:21
Daniel
in A2 steht aber kein Fehlerwert
02.07.2017 12:43:09
WF
ich antworte entsprechend Frage/Datei.
WF
AW: in A2 steht aber kein Fehlerwert
02.07.2017 17:22:41
Daniel
Vielleicht habe ich die Fragestellung ja nicht genau gelesen, aber wo stand in der Frage, dass ein Fehler nur dann in Spalte B (bzw A) vorkommen kann, wenn die Bedingung für die Spalte E in der gleichen Zeile NICHT erfüllt ist?
Wurde dieser Fall in der Fragestellung explizit ausgeschlossen? Ich meine ja, aber du kannst mir die entsprechende Textzeile, die ich da überlesen habe, gerne zeigen.
Gruß Daniel
Anzeige
AW: summenprodukt wenn nicht wert
02.07.2017 11:10:59
Daniel
Hi
ersetze in deiner Formel jedes --$B$2:$B$10000 durch Wennfehler(--$B$2:$B$10000;0)
allerdings musst du dann die Formel als Matrixformel eingeben, dh du musst die Eingabe jedesmal mit STRG+SHIFT+ENTER abschließen.
=SUMMENPRODUKT(--($E$2:$E$10000=J$8);WENNFEHLER(--$B$2:$B$10000;0)) -SUMMENPRODUKT(--($E$2:$E$10000=J$8);--($F$2:$F$10000J$8);--($F$2:$F$10000"1900/01"); WENNFEHLER(--$B$2:$B$10000;0))+SUMMENPRODUKT(--($E$2:$E$10000J$8);--($F$2:$F$10000=J$8); WENNFEHLER(--$B$2:$B$10000;0))
Gruß Daniel
AW: summenprodukt wenn nicht wert
02.07.2017 12:20:06
hans
Moin Daniel,
vielen Dank!! Jetzt funktioniert es.
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige