Wenn funktion funktioniert nur teilweise

Bild

Betrifft: Wenn funktion funktioniert nur teilweise
von: eva
Geschrieben am: 21.04.2005 16:29:16
Hallo,
eine einfache Wenn Funktion funktioniert nur teilweise bei mir, manche Zeilen werden einfach nicht berechnet.
Einen offensichtlichen Fehler gibt es wohl nicht. Weiß jemand Rat?
Danke+Gruß
Eva

Bild

Betrifft: wo ist meine Glaskugel?
von: Günther Oppold
Geschrieben am: 21.04.2005 16:33:54
Hallo Eva
wie soll man Dir helfen, wenn Du die Sache nicht genauer erklärst?
Wie lautet die Formel die funktioniert, wie die, die nicht funtioniert?
evtl. sind die Zellen als Text formatiert und nicht als Zahlen.
Prüfe wie die Zelle (ohne spezielle Vorgabe) formatiert ist. Rechtsbündig = Zahl, linksbündig = Text
Günther
Bild

Betrifft: nun gut
von: eva
Geschrieben am: 21.04.2005 16:47:32
Hallo Günther,
es sind drei Bedingungsabfragen in drei aufeinanderfolgenden Spalten
=WENN($X98=1;$W98;0) =WENN($X98=2;$W98;0) =WENN($X98=3;$W98;0)
habe alles gleich formatiert und trotzdem gibt es bei manchen Zeilen einfach keine Berechnung. kann das Fehlerbild in der Glaskugel schärfer werden?
Gruß
Eva
Bild

Betrifft: AW: nun gut
von: M@x
Geschrieben am: 21.04.2005 16:59:06
Hi Eva,
da immer eine Zeile ausfällt, scheint das schon sehr am falschen Format zu liegen,
wie kommen die Zahlenwerte in X98??
Gruss
M@x
Bild

Betrifft: AW: nun gut
von: eva
Geschrieben am: 21.04.2005 17:01:16
Hallo Max,
diese wurden manuell eingepflegt -
Bild

Betrifft: AW: nun gut
von: M@x
Geschrieben am: 21.04.2005 17:13:42
Hi
Wenns nicht am Format liegt, fällt mir momentan nix ein.
stell doch den File oder einen Teil davon ins Forum,
Gruss
M@x
Bild

Betrifft: erledigt
von: eva
Geschrieben am: 21.04.2005 17:17:29
habs mit einer einmaligen Formatkonvertierung text in zahl geschafft.
leider schafft man es nicht über Spalte markieren und Zellen formatieren auf zahl.
Danke für die Mühe
Eva
Bild

Betrifft: AW: erledigt
von: Beate Schmitz
Geschrieben am: 21.04.2005 18:44:40
Hallo Eva,
es gehören keine "="-Zeichen in die Formel, nur Strichpunkte:
 
 AB
1Lang:5
2Kurz:5
Formeln der Tabelle
B1 : =WENN($X98=1;$W98;WENN($X98=2;$W98;WENN($X98=3;$W98;0)))
B2 : =WENN(ODER($X98=1;$X98=2;$X98=3);$W98;0)
 


Gruß,
Beate
Bild

Betrifft: AW: erledigt
von: M@x
Geschrieben am: 21.04.2005 20:47:58
@ Beate
eva Schreibt:
es sind drei Bedingungsabfragen in drei aufeinanderfolgenden Spalten
=WENN($X98=1;$W98;0) =WENN($X98=2;$W98;0) =WENN($X98=3;$W98;0)
es sind also 3 Formeln.
@ Eva,
Ja die Formatierung von Text in Zahl geht leider nicht einfacher.
da muß aber schon das Feld als Text vorformatiert gewesen sein
Gruss
M@x
Bild

Betrifft: Textzahlen konvertieren
von: Beate Schmitz
Geschrieben am: 21.04.2005 20:54:27
Hallo Max,
au ja, das habe ich überlesen.
Hallo Eva,
hier ist noch eine Beschreibung, wie man "Textzahlen" in "echte Zahlen" konvertiert:
Guckst Du: Textzahlen konvertieren
Gruß,
Beate
Bild

Betrifft: AW: noch kürzer?erledigt
von: Gert Seler
Geschrieben am: 22.04.2005 12:02:38
Hallo Eva + Beate,
Formel noch kürzer :
=WENN(UND($X98>=1;$X98<=3);$W98;0)
mfg
Gert
Bild

Betrifft: =$W98*oder($X98={1.2.3})
von: ingoG
Geschrieben am: 22.04.2005 12:35:02
Hallo zusammen,
oder kurz ;-)
Gruß Ingo
Bild

Betrifft: AW: @Gerd
von: HermannZ
Geschrieben am: 22.04.2005 12:35:05
Hallo Gerd,
wenns darum geht,
geht noch kürzer;
=SUMME(($X98={1.2.3})*$W98)
Gruß hermann
Bild

Betrifft: AW: @Gerd
von: Gert Seler
Geschrieben am: 24.04.2005 11:00:30
Hallo Hermann und Ingo,
es ist doch erstaunlich, wie mit der Zeit eine Formel sich verkuerzt.
Danke
mfg
Gert
Bild

Betrifft: Danke für die Rückmeldung oT
von: IngoG
Geschrieben am: 26.04.2005 00:11:01
.
Bild

Betrifft: AW: nun gut
von: ingoG
Geschrieben am: 21.04.2005 17:01:13
HAllo Eva,
markiere mal in einer Zelle, in der Du ein ergebnis erwartest den Term $X98 und Drücke F9.
Dann siehst Du, was excel denkt, was in der Zelle steht.
Du kannst auch $X98=1 markieren und F9 drücken. wenn dann nicht wahr rauskommt, ist einfach der Zellinhalt nicht = 1 ...
Gruß Ingo
PS eine Rückmeldung wäre nett...
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wenn funktion funktioniert nur teilweise"