Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Userform
BildScreenshot zu Userform Userform-Seite mit Beispielarbeitsmappe aufrufen
Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

Wert wird in Text umgewandelt!!!!

    Betrifft: Wert wird in Text umgewandelt!!!! von: Pippo
    Geschrieben am: 02.10.2003 10:50:45

    Hallo Excelexperten,

    ich komme nicht weiter und brauche eure Hilfe:
    ich lese der Wert eine Zelle (mit Formel) aus ein Textfeld. Alles schön und gut!
    Wenn der Userform schliesse, wird der Wert der Zelle in Text umgewandelt.....und die Formel ist weg!!! Wie Kann ich es verhindern?
    DANKE,
    Pippo

      


    Betrifft: AW: Wert wird in Text umgewandelt!!!! von: Galenzo
    Geschrieben am: 02.10.2003 10:57:36

    Hallo,

    etwas Code würde weiterhelfen....
    Vermutung: Nimm statt .value .formula


      


    Betrifft: AW: Wert wird in Text umgewandelt!!!! von: Pippo
    Geschrieben am: 02.10.2003 11:05:46

    Hallo Galenzo,
    Habe kein Code.
    habe alles in die Eigenschaften von UserForm unter ControlSource eingegeben.
    Falls ein Code notwendig ist, kannst du mir sagen wie soll es lauten.

    der TextBox name ist "Textbox1", die Formel ist
    =SUMMENPRODUKT(($B8:$B52="Piano")*(LINKS(F7:F51)="F"))

    Danke Pippo


      


    Betrifft: AW: Wert wird in Text umgewandelt!!!! von: Galenzo
    Geschrieben am: 02.10.2003 11:17:29

    Hallo,

    ich habe dein Problem wahrscheinlich noch nicht richtig verstanden - deshalb hier zwei Möglichkeiten.
    1. In der Textbox soll die FORMEL, die (z.B.) Zelle A1 steht angezeigt werden:


    Private Sub UserForm_Activate()
        TextBox1.Value = Sheets("Tabelle1").Range("A1").Formula
    End Sub

    2. In der Textbox soll der WERT, der (z.B.) in Zelle A1 steht angezeigt werden:


    Private Sub UserForm_Activate()
        TextBox1.Value = Sheets("Tabelle1").Range("A1").value
    End Sub

    Die Prozeduren gibst du im Modul ein, das zur Userform1 gehört. Die Textbox wird bei Aktivierung der Userform gefüllt. Du kannst die Werte natürlich auch über einen Button oder über andere Ereignisse eintagen lassen.

    Viel Erfolg!


      


    Betrifft: AW: Wert wird in Text umgewandelt!!!! von: daniel
    Geschrieben am: 02.10.2003 11:27:22

    Hallo Galenzo,
    die 2. Möglichkeit ist die richtige. Das Problem besteht immer noch.
    Wenn ich der UF schliesse wird der Wert umgewandelt und die Formel ist weg!!
    Weß Du Rat?
    Danke.Pippo


      


    Betrifft: AW: Wert wird in Text umgewandelt!!!! von: Galenzo
    Geschrieben am: 02.10.2003 11:40:29

    Sorry, ich weiß immernoch nicht, was du damit bezweckst. Daher zweifle ich auch gerade an meinem Lösungsansatz. Also soll in der Tabelle die Formel zu sehen sein und in der Textbox der Wert?
    ...


      


    Betrifft: AW: Wert wird in Text umgewandelt!!!! von: Pippo
    Geschrieben am: 02.10.2003 11:51:38

    hallo Galenzo,
    in der Tabelle in A1 steht =SUMMENPRODUKT(($B8:$B52="Piano")*(LINKS(F7:F51)="F")).
    Der Wert ist zB.: 6. In der TextBox1 erscheint also 6 . Wenn der UserForm schliesse steht in
    A1 noch 6, aber die Zelle hat keine Formel mehr und kann nicht mehr rechnen.
    wenn in F7:F51 ein "F" weniger ist, A1 bleibt immer 6 (statt5), da die Zelle keine Formel mehr hat.
    Ich hoffe, dass du mich verstanden hast.
    Ciao.
    Pippo




      


    Betrifft: AW: Wert wird in Text umgewandelt!!!! von: pippo
    Geschrieben am: 02.10.2003 12:22:03

    Hallo Galenzo,
    hatte ich vergessen in die Eingensschaften ControlSource zu löschen!!!!
    Problem gelöst!!
    Sorry für die Umständen
    Ciao Pippo
    und
    Danke nochmal


      


    Betrifft: AW: OK (oT) von: Galenzo
    Geschrieben am: 02.10.2003 12:33:54