Microsoft Excel

Herbers Excel/VBA-Archiv

Formel in Zelle per Makro

Betrifft: Formel in Zelle per Makro von: Peter
Geschrieben am: 27.08.2004 12:44:49

Hallo,
weiß jemand wie ich per Makro eine Formel in eine Zelle bekomme?
Mit Range("A1").Value = "=SUMME(A2:A3)" und mit Cells(1, 1).Value = .... kommt immer #NAME? in das Feld...
An der Formel liegt es nicht, denn wenn ich in Excel das Feld anklicke und Enterdrücke, die Formal also sozusagen noch einmal bestätige, geht es.

Danke

  


Betrifft: AW: Formel in Zelle per Makro von: Werner
Geschrieben am: 27.08.2004 12:49:14

Range("A1").FormulaLocal = "=SUMME(A2:A3)"

Gruss Werner


  


Betrifft: ActiveCell.FormulaR1C1 = "=SUM(R[1]C:R[2]C)" von: Wolfgang
Geschrieben am: 27.08.2004 12:49:56




  


Betrifft: AW: Formel in Zelle per Makro von: Rudi
Geschrieben am: 27.08.2004 12:50:31

Hallo Peter

das geht folgendermassen (Beispiel):

Range("a1").value = Application.WorksheetFunction.Sum(Range("A3:A5"))

Gruss
Rudi


  


Betrifft: AW: Formel in Zelle per Makro von: Rudi
Geschrieben am: 27.08.2004 12:52:11

Sorry, du brauchst ja die Formel in die Zelle geschrieben. Dann ist natürlich die erste Antwort richtig.

Gruss Rudi


 

Beiträge aus den Excel-Beispielen zum Thema "Formel in Zelle per Makro"