Microsoft Excel

Herbers Excel/VBA-Archiv

Formel per VBA in Zelle eintragen

Betrifft: Formel per VBA in Zelle eintragen von: Georg
Geschrieben am: 25.03.2020 09:41:43

Hallo zusammen,

ich versuche leider vergeblich eine Formel mittels Makro in eine Zelle zu schreiben.

Die Zeile im Makro sieht auktuell wie folgt aus:

.Cells(zeile, Spalte).FormulaLocal = "=WENN(ISTFEHLER(LINKS(AI9;FINDEN(".";AI9)-1));WENN(ISTFEHLER(FINDEN("PEW";AI9));WENN(ISTFEHLER(FINDEN("PAW";AI9));"nix gefunden";LINKS(AI9;9));LINKS(AI9;9));LINKS(AI9;FINDEN(".";AI9)-1)) "
Bei dem ersten ":" in der Formel meckert Excel mit der Meldung "Fehler beim Kompilieren: Erwartet: Anweisungsende"

Ich werde da aktuell nicht so schlau draus. Die Formel soll doch quasi nur als String reingeschrieben werden.
Hat hier jemand einen Tipp für mich?

LG Georg

Betrifft: AW: Formel per VBA in Zelle eintragen
von: Werner
Geschrieben am: 25.03.2020 09:46:53

Hallo,

alle Gänsefüßchen (") innerhalb der Formel müssen gedoppelt werden.

z.B.: ...FINDEN(""."";A19....

Gruß Werner

Betrifft: AW: Formel per VBA in Zelle eintragen
von: Georg
Geschrieben am: 25.03.2020 09:51:51

Hallo Werner,

vielen Dank! Funktioniert jetzt wie es soll.

Betrifft: Gerne u. Danke für die Rückmeldung. o.w.T.
von: Werner
Geschrieben am: 25.03.2020 10:00:50



Beiträge aus dem Excel-Forum zum Thema "Formel per VBA in Zelle eintragen"