Microsoft Excel

Herbers Excel/VBA-Archiv

Formel Format

Betrifft: Formel Format von: serge
Geschrieben am: 11.08.2008 11:04:04

Hallo Leute
wie kann ich den letzten Teil meiner Formel,
---$J$4/100*D22))&" ("&WENN(G22=" ";0;$J$4/100*D22)&")"---
formatieren, er sollte als Zahl mit einer Stelle nach dem Komma sein?
meine Formel:

=WENN(E22>0;(WENN(G22=" ";0;$J$4/100*D22))/C22*E22;WENN(G22=" ";0;$J$4/100*D22)) &" ("&WENN(G22=" ";0;$J$4/100*D22)&") "

jetziges Resultat:
47.5 (72.225)

gewünschtes Resultat:
47.5 (72.2)

Danke im Voraus
Serge

  

Betrifft: AW: Formel Format von: Tobias
Geschrieben am: 11.08.2008 11:06:00

Mit der Funktion TEXT?

=TEXT(2,39483;"0,0")

Schönen Gruß, Tobias
http://www.tobiasschmid.de/


  

Betrifft: aber wie? von: serge
Geschrieben am: 11.08.2008 11:16:29

Hallo Tobias
danke für deine Antwort!

Aber wie bekomme ich das in meine Teilformel?

Serge


  

Betrifft: AW: aber wie? von: Tobias
Geschrieben am: 11.08.2008 11:22:30

Hallo Serge!
So?

=WENN(E22>0;(WENN(G22=" ";0;$J$4/100*D22))/C22*E22;WENN(G22=" ";0;$J$4/100*D22)) &" ("& TEXT(WENN(G22=" ";0;$J$4/100*D22);"0,0") &") "

Viele Grüße, Tobias
http://www.tobiasschmid.de/


  

Betrifft: Es Klappt von: serge
Geschrieben am: 11.08.2008 11:38:03

Danke Tobias
ich habe es angepasst und es klappt!
Super
Gruss
Serge


 

Beiträge aus den Excel-Beispielen zum Thema "Formel Format"