Microsoft Excel

Herbers Excel/VBA-Archiv

Matrixformel - woran liegt es? | Herbers Excel-Forum


Betrifft: Matrixformel - woran liegt es? von: Jean Gitanes
Geschrieben am: 21.10.2008 22:18:33

Hallo,

in Spalte A befinden sich Zeichenketten wie zB
AX45H33
B923K37F

Mit der folgenden Matrixformel sollte die Quersumme des Zahlenteils ermittelt werden, leider ohne Erfolg.

{=summe(wenn(istZahl(1*teil(A6;zeile(indirekt("1:"& länge(A6)));1);1*teil(A6; zeile(indirekt("1:" & länge(A6)));1);0))) }

Ist der Ansatz völlig falsch, ist die Klammersetzung falsch oder ...

Bei der Formel handelt es sich um den Versuch, eine funktionierende Formel von Peter Haserodt an den geänderten Sachverhalt anzupassen

Wer kann helfen?

Gruß

Jean

  

Betrifft: Quersumme gemischte Strings von: Beate Schmitz
Geschrieben am: 21.10.2008 22:36:09

Hallo Jean,

hier mit Hilfsspalte:

 ABC
1 HilfsspalteErgebnis
2AX45H33453315
3B923K37F9233724
4 http://www.excelformeln.de/formeln.html?welcher=103http://www.excelformeln.de/formeln.html?welcher=112

Formeln der Tabelle
ZelleFormel
B2{=SUMME((TEIL(0&A2;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&A2;ZEILE($1:$256);1)*1);ZEILE($1:$256);1);ZEILE($1:$256));1)*1)*10^(ZEILE($1:$256)-1))}
C2=SUMMENPRODUKT((0&TEIL(B2;SPALTE(1:1);1))*1)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Gruß,
Beate


  

Betrifft: AW: Quersumme gemischte Strings von: Jean Gitanes
Geschrieben am: 21.10.2008 22:48:35

Hallo Beate,

ich danke Dir für Deine Lösung. Damit ist die Aufgabe gelöst.
Eine Lösung o h n e Hilfsspalte überschreitet Excels Grenzen?

Gruß

Jean


  

Betrifft: AW: Matrixformel - woran liegt es? von: Uduuh
Geschrieben am: 21.10.2008 22:53:10

Hallo,
{=SUMME(WENN(ISTZAHL(--TEIL(A6;ZEILE(INDIREKT("1:"&LÄNGE(A6)));1));--TEIL(A6; ZEILE(INDIREKT("1:"&LÄNGE(A6)));1));0) }

Gruß aus’m Pott
Udo



  

Betrifft: AW: Matrixformel - woran liegt es? von: Jean Gitanes
Geschrieben am: 22.10.2008 08:07:01

Guten Morgen Udo,

ja, so sollte die Formel funktionieren.
Vielen Dank dafür.

Eine Frage ist noch offen: Manchmal sieht man ein - Zeichen oder wie in Deiner Formel 2 - Zeichen.
Welche Bedeutung haben diese "Abkürzungen"?

Einen schönen Tag.

Gruß

Jean


Beiträge aus den Excel-Beispielen zum Thema "Matrixformel - woran liegt es?"