Microsoft Excel

Herbers Excel/VBA-Archiv

Inhalte in aufeinanderfolgenden Zellen zählen | Herbers Excel-Forum


Betrifft: Inhalte in aufeinanderfolgenden Zellen zählen von: Armin
Geschrieben am: 24.11.2009 09:00:56

Hallo,

ich habe folgendes Problem:

Folgende Inhalte habe ich in meiner Tabelle:

A1 = 1
A2 = 1
A3 = 1
A4 = kein Inhalt
A5 = kein Inhalt
A6 = kein Inhalt
A7 = 1
A8 = 1
A9 = kein Inhalt
A10 = kein Inhalt
A11 = 1

Ich möchte nun prüfen, ob in dieser Ziele von A1 bis A11 drei aufeinanderfolgene Zeilen keinen Inhalt haben, also leer sind. Nur wenn dies der Fall ist, soll ein entsprechender Hinweis ausgegeben werden. Zwei leere Zelle spielen keine Rolle. In diesem Fall ist der Tatbestand erfüllt, da in Zelle A4 bis A6 kein Inhalt in den Zellen vorhanden ist.

Gibt es dafür eine Formellösung?

Vielen Dank für euere Tipps und Tricks.

Armin

  

Betrifft: AW: Inhalte in aufeinanderfolgenden Zellen zählen von: serge
Geschrieben am: 24.11.2009 09:09:23

Hallo Armin
in B3 =WENN(ZÄHLENWENN(A1:A3;"")=>3;"Meldung";"") und herunterkopieren
Serge


Beiträge aus den Excel-Beispielen zum Thema "Inhalte in aufeinanderfolgenden Zellen zählen"