Jetzt Formel



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Jetzt Formel
von: Björn
Geschrieben am: 05.07.2002 - 13:36:09

Könnt ihr mir helfen??

Ich muss ein Ablaufprotokoll schreiben und will in A1 immer die aktuelle Uhrzeit rein haben, wenn ich in B1 was reinschreibe.

meine Formel in A 1 ist:

=WENN(B1="";"";JETZT())

Problem ist nur, dass er immer in die Spalte A die aktuelle zeit rein schreibt, die soll aber stehen bleiben...

A B
1 13:11 test
2 13:11 test
3 13:11 Hallo
4 13:11 r
5 13:11 test
6 13:11 123
7 13:11 test

Also wenn ich in B7 was schreibe, soll in A7 die "NEUE" aktuelle Zeit stehen, Excel schreibt aber in alle Zellen von A immer die "NEUE" zeit rein???


Hilfe!!!!!!!!!!!!!!!!!!

Grüße von Bjørn

nach oben   nach unten

Re: Jetzt Formel
von: Josef_i
Geschrieben am: 05.07.2002 - 14:11:25

Hallo Björn,

Ein Vorteil der eingebauten Funktionen ist daß bei jedem Neuberechnen des Blattes diese berechnet werden. In Deinem Fall ist das aber schlecht (s.o).

Lösung : unten angegebene Funktion in das Visual Basic Modul 1 eintragen. Aufrufen in Zelle A1: = Zeiteintrag(B1). Die Formel soweit in Spalte A runterziehen, wie gebraucht. Zellenformat auf Zeit stellen.

Function Zeiteintrag(zelle)
If zelle = "" Then
Zeiteintrag = ""
Exit Function
End If
heute = Now
Zeiteintrag = heute
End Function

Vui Spaß

nach oben   nach unten

Re: Jetzt Formel
von: Björn
Geschrieben am: 05.07.2002 - 19:21:58

Und wie baue ich diese Funktion wo ein??? Bin Anfänger...

Danke im voraus


nach oben   nach unten

Re: Jetzt Formel
von: Josef_I
Geschrieben am: 08.07.2002 - 11:16:23

Hallo Björn,

Oiso, Menü Extras - Makro - Visual Basic
Wenn es keine Auflistung Module gibt mit Einfügen - Modul eines einfügen.
Das Modul (z.B. Modul 1) mit Doppelclick öffnen und Code hierein kopieren. Dann VBA - Editor im Dateimenü schließen und Du bist wieder in EXCEL. Jetzt trägst Du in die Zelle A1 folgendes ein : = Zeiteitrag(B1) und kopierst das in Spalte A soweit Due es brauchst.

Viel Spaß, Josef

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Jetzt Formel"