Microsoft Excel

Herbers Excel/VBA-Archiv

Was ist hier falsch?

Betrifft: Was ist hier falsch? von: Udo Kowalleck
Geschrieben am: 12.08.2014 16:45:52

Hallo,
Anfänger Udo hat eine Frage:
Was ist hier falsch?
Cells(zeile, spalte).FormulaLocal = "=WENN(G5="";"";WENN(H5="";"";G5:H5))"
Im Tabellenblatt erscheint:
=WENN(G5=";";WENN(H5=";";G5:H5))
Wo ist jeweils das zweite doppelte Hochkomma geblieben?
Ich freue mich auf eure Antwort.

  

Betrifft: fehlende ""...... von: robert
Geschrieben am: 12.08.2014 16:56:53

Cells(Zeile,Spalte).FormulaLocal = "=WENN(G5="""";"""";WENN(H5="""";"""";G5:H5))"

..aber was soll G:H ?

Gruß
robert


  

Betrifft: AW: fehlende ""...... von: Udo Kowalleck
Geschrieben am: 12.08.2014 17:35:04

Danke für Deine schnelle Antwort. Leider ist das nicht die Lösung.
Wenn ich diese Formel direkt im Tabellenblatt Spalte I5 eingebe WENN (G5="";"";WENN(H5="";"";G5+H5))
funkt es selbstverständlich, Warum nicht bei FormulaLocal? Auch verstehe ich nicht in Deiner Antwort das dritte doppelte Hochkomma.


  

Betrifft: probier das mal.... von: robert
Geschrieben am: 12.08.2014 17:41:06

Sub tt()
Cells(2, 2).FormulaLocal = "=WENN(G5="""";"""";WENN(H5="""";"""";G5+H5))"
End Sub
"" ist ein Text, daher vorne """" und hinten ..........

Gruß
robert


  

Betrifft: AW: probier das mal.... von: Udo Kowalleck
Geschrieben am: 12.08.2014 17:50:37

Nein das ist kein Text! Wenn in der Celle G5 nichts enthalten ist (""), sie ist also leer, dann soll auch in Cells(2, 2) als Ergebnis nichts stehen.


  

Betrifft: Du sollst das probieren !.. von: robert
Geschrieben am: 12.08.2014 17:57:35

..und keine unsinnigen Antworten schreiben!

So macht Hilfe wirklich Spass!

Finito


  

Betrifft: AW: fehlende ""...... von: Daniel
Geschrieben am: 12.08.2014 17:51:09

Hi

wenn du die Formel direkt in die Zelle eingibst, dann benutzt du am Anfang und am Ende der Formel ja keine Anführungszeichen um Anfang und Ende des Formeltextes zu kennzeichnen.

In der VBA-Programmierung jedoch musst du einen Text wie die Formel in Anführungszeichen setzten, damit der VBA-Compiler weiss, wo der freie Text anfängt und aufhört und wo die Programmanweisungen weitergehen.
Dabei entsteht das Problem, dass der Compiler noch irgendwie unterscheiden muss zwischen den Anführungszeichen, die den Text begrenzen und den Anführungszeichen die Bestandteil des Textes sind.

In VBA wurde das so gelöst, dass Anführungszeichen die zum Text gehören immer doppelt eingegeben werden (" wird zu "") und die Begrenzungsanführungszeichen einfach bleiben.

Gruß Daniel


  

Betrifft: AW: fehlende ""...... von: Udo Kowalleck
Geschrieben am: 12.08.2014 18:04:13

Danke Daniel. Das war die richtige Antwort und Lösung.
Auch Dank an Falk, der die Frage wohl leider nicht richtig verstanden hat (mein Fehler).


  

Betrifft: AW: fehlende ""...... von: Adis
Geschrieben am: 12.08.2014 20:24:57

Hallo

ich weiss nicht ob ich die Formel richtig verstanden habe.
Statt Leere Zelle mit "" auszuwerten kann man auch G5 > 0 benutzen.
Anbei zwei Formeln die ich mal auf die schnell getestet habe.

Cells(5, 3).FormulaLocal = "=WENN(G5="""";"""";WENN(H5="""";"""";G4+H5))"
Cells(7, 3).FormulaLocal = "=WENN(G7>0;WENN(H7>0;G7+H7);"""")"

Gruss Adis


  

Betrifft: Ja, das ist richtig, ... von: Luc:-?
Geschrieben am: 12.08.2014 21:18:57

…Adis,
LeerZellen wdn als vom Wert 0 interpretiert (alternativ aber auch Leer-String). Aber, wer weiß, ob die wirklich leer sind oder nur so aussehen. Um das richtig darzustellen verfügt Udo ggf nicht über einen ausreichenden KenntnisStand (vgl seine Level-Angabe).
Gruß, Luc :-?

Besser informiert mit …


  

Betrifft: Wer ist Falk? Falls du damit robert meinen ... von: Luc:-?
Geschrieben am: 12.08.2014 21:14:04

…solltest, Udo,
so hat der deine Frage nicht nur richtig verstanden, sondern auch die richtige AW gegeben. Dafür, dass du diese erst nach Daniels (narrensicherer) Erklärung verstanden hast, kann robert nichts. Wer sich an eine Pgmiersprache wie VBA heranwagt, sollte sich schon mal wenigstens etwas mit den Grundlagen beschäftigen oder zumindest so flexibel sein, dass er nicht auf seinem Unverständnis beharrt. Das lieben wir nämlich gar nicht! :-|
Gruß, Luc :-?

Besser informiert mit …


  

Betrifft: AW: Wer ist Falk? Falls du damit robert meinen ... von: Udo Kowalleck
Geschrieben am: 13.08.2014 16:51:29

Hallo Luc,
harte Worte. So war es nicht gemeint und es tut mir aufrichtig leid sollte ich robert gekränkt haben. Ich habe aber auch geschrieben:mein Fehler. Das ich als blutiger Anfänger einiges nicht auf Anhieb verstehe, ist logisch und ich bin flexibel. Außerdem habe ich mich bei beiden bedankt, was selbstverständlich ist.
Von daher finde ich deine "Abmahnung" ein wenig überzogen.
Gruß Udo


  

Betrifft: AW: Wer ist Falk? Falls du damit robert meinen ... von: Daniel
Geschrieben am: 13.08.2014 16:56:01

HI Udo
da braucht dir eigentlich nichts leid zu tun.
Robert hat zwar die richtige Lösung gepostet, aber nunmal nichts dazu geschrieben, was du hättest verstehen können müssen.
Gruß Daniel


 

Beiträge aus den Excel-Beispielen zum Thema "Was ist hier falsch?"