Microsoft Excel

Herbers Excel/VBA-Archiv

Mit Kalenderwoche im Format 2014/42 rechnen

Betrifft: Mit Kalenderwoche im Format 2014/42 rechnen von: Christian
Geschrieben am: 15.10.2014 12:58:34

Hallo zusammen,

ich ermittle in einer Tabelle mit vielen Tagesdatumswerten mithilfe der Formel
=JAHR(Q9)&"/"&KÜRZEN((Q9-DATUM(JAHR(Q9+3-REST(Q9-2;7));1;REST(Q9-2;7)-9))/7) eine Kalenderwoche im Format 2014/42

in eine Zelle E26 schreibe ich die aktuelle Woche z.B. 2014/42 und versuche dann in anderen Zellen mit Bezug auf diese Woche Summen zu ermitteln.
=SUMMEWENN('In Arbeit'!$AF$4:$AF$599;"="&$E$26;'In Arbeit'!$L$4:$L$219)

Das soll für die Werte kleiner E26 gleich E26 und für die nächsten 4 Wochen in die Zukunft funktionieren. Für kleiner und gleich funktioniert es auch sehr gut, allerdings wenn ich nun für die Zukunft E26+1, E26+2 etc mache dann geht es nicht mehr. Hat jemand eine Idee wie ich mit 2014/42 in die Zukunft rechnen kann?

Vielen DAnk und viele Grüsse
Christian

  

Betrifft: ermittele den Wert aus der Basis ... von: neopa C (paneo)
Geschrieben am: 15.10.2014 14:46:31

Hallo Christian,

... also anstelle E26+1 einfach zu dem Zellendatum in Q9 7 (Tage) addieren für eine zusätzliche Woche

=JAHR(Q9+7)&"/"&KÜRZEN((Q9+7-DATUM(JAHR(Q9+10-REST(Q9+7-2;7));1;REST(Q9+7-2;7)-9))/7) und analog für weitere Wochen. Alles andere musst Du vergessen.

Gruß Werner
.. , - ...


  

Betrifft: AW: ermittele den Wert aus der Basis ... von: Christian
Geschrieben am: 15.10.2014 17:14:37

Hallo Werner,

vielen Dank, ich habe die gesamte Formel als Suchkriterium in die SUMMEWENN-Formel eingebaut und das funktioniert gut. Super! Danke

Gruss
Christian


 

Beiträge aus den Excel-Beispielen zum Thema "Mit Kalenderwoche im Format 2014/42 rechnen"