Microsoft Excel

Herbers Excel/VBA-Archiv

VBA Excel Zählen Wenn

Betrifft: VBA Excel Zählen Wenn von: Thomas
Geschrieben am: 24.11.2014 09:41:24

Guten Morgen liebe Community,

ich habe folgendes vor:

In Spalte A stehen insgesamt 4 verschiedene Werte kontinuierlich: A, B, C oder D.

In Spalte B stehen Zahlen von - x,xxxxx bis x,xxxxx.

Jetzt soll ein Makro zählen wenn es eine negative Zahl in Spalte B gibt und überprüfen was es für einen Wert in Spalte A besitzt und diesen Wert zählen.

Damit ich eine Übersicht bekomme wieviele negative A, B, C oder D Werte es insgesamt gibt.

Vielen Dank für eure Hilfe!

Grüsse Thomas

  

Betrifft: AW: VBA Excel Zählen Wenn von: Thomas
Geschrieben am: 24.11.2014 09:46:32

Achja: In der Spalte A sind die Werte nicht in Textform sondern setzen sich zusammen aus einer Formel.

Grüsse


  

Betrifft: ZählenWennS von: Matthias L
Geschrieben am: 24.11.2014 10:09:08

Hallo

 ABCD
1A433C
2B94  
3C47  
4D-13  
5A-5  
6B-59  
7C-44  
8D8  
9A34  
10B-92  
11C-82  
12D-17  
13A21  
14B-9  
15C19  
16D31  
17A88  
18B53  
19C-86  
20D38  

Formeln der Tabelle
ZelleFormel
C1=ZÄHLENWENNS(B1:B20;"<" & 0;A1:A20;D1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


 

Beiträge aus den Excel-Beispielen zum Thema "VBA Excel Zählen Wenn "