Microsoft Excel

Herbers Excel/VBA-Archiv

Tabellenbereich - Verweis auf andere Zeilen | Herbers Excel-Forum


Betrifft: Tabellenbereich - Verweis auf andere Zeilen von: André
Geschrieben am: 20.01.2010 14:31:59

Moin zusammen,

ich habe in einem Arbeitsblatt einen Bereich als "Tabelle" definiert. In dieser Tabelle erfasse ich Arbeitszeiten.
Also, in jeder Zeile steht ein Datum, eine "kommen"-Zeit und eine "gehen"-Zeit. Dann noch eine Spalte, in der die Arbeitszeit, also die Differenz zwischen "kommen" und "gehen" berechnet wird.
Pro Tag können mehrere Zeilen vorhanden sein, da "kommen" und "gehen" bei jeder Pause erfaßt wird.
In der letzten Spalte habe ich eine Formel, welche mir die Pausenzeit ermittelt; aber nur dann, wenn das Datum der aktuellen Zeile gleich dem Datum der folgenden Zeile ist.

Problem: in der letzten Zeile der Tabelle verweist die Formel (Pausenzeit) auf die Zeile unterhalb der Tabelle. Füge ich nun eine weitere Zeile am Ende der Tabelle an, so verschiebt sich in dieser Zelle der Verweis um eine Zeile, stimmt also dann nicht mehr.

Ich habe mal eine kleine Beispieltabelle angehängt. Am besten mal selbst ausprobieren, eine weitere Zeile anzuhängen und dabei die Formel in den letzten Spalte zu beobachten.

Wie kann ich die Formel so formulieren, daß sie auch nach dem Anfügen neuer Zeilen funktioniert?

Gruß, André

https://www.herber.de/bbs/user/67348.xlsx

  

Betrifft: AW: Tabellenbereich - Verweis auf andere Zeilen von: robert
Geschrieben am: 20.01.2010 16:18:47

hi,

probier das mal, ob es passt

gruß
robert

https://www.herber.de/bbs/user/67351.xlsx


  

Betrifft: AW: Tabellenbereich - Verweis auf andere Zeilen von: André
Geschrieben am: 21.01.2010 09:09:48

Moin Robert,

erst mal danke für die Hilfe. Leider passt es so noch nicht.
Einerseits sind die Werte in den ersten beiden Tabellenzeilen identisch, weil Du in der ersten Zeile eine von der Spaltenformel abweichende Formel stehen hast. Das könnte man noch lösen, indem man in der ersten Zeile die Spaltenformel benutzt.
Mein Problem ist aber, daß nun die Pausenzeiten in jeweils der falschen Zeile stehen. Ich brauche tatsächlich die Pausenzeit in der Zeile, in der auch der Pausenbeginn steht. Ich muß also eine Formel finden, die die aktuelle Zeile mit der nächsten vergleicht (Datum), nicht mit der vorherigen.

Gruß, André


  

Betrifft: was willst du vergleichen.. von: robert
Geschrieben am: 21.01.2010 09:30:28

hi,

..wenn in der nächsten noch nichts drin steht?

zeig mal an einem beispiel, was du dir vorstellst.

gruß
robert


  

Betrifft: AW: was willst du vergleichen.. von: André
Geschrieben am: 21.01.2010 09:46:21

Moin Robert,

ein Beispiel hängt doch an meinem ersten Post dran.
Klar kann ich erst vergleichen, wenn in der nächsten Zeile etwas steht, deswegen wird ja auch mit einer Wenn-Bedingung abgefragt, ob in der nächsten Zeile etwas steht. Blöd ist eben nur, daß wenn ich dann eine neue Zeile anfüge, die Formel in der bisher letzten Zeile dann auf die übernächste und nicht auf die nächste Zeile verweist.

Gruß, André


  

Betrifft: vergleiche Formel E8 mit E9... owT-Gruß von: robert
Geschrieben am: 21.01.2010 11:05:00




  

Betrifft: AW: vergleiche Formel E8 mit E9... owT-Gruß von: André
Geschrieben am: 21.01.2010 11:12:08

Öhm, ja?
In beiden Zellen (E8 und E9) steht die gleiche Formel, die jeweils Zelle in Spalte A aus der eigenen Zeile mit dem aus der nachfolgenden Zeile vergleicht. Und wie hilft mir das jetzt weiter?

Gruß, André


  

Betrifft: bitte GENAU schauen.. von: robert
Geschrieben am: 21.01.2010 11:43:38

hi,

ich weiss nicht, ob das die kösung ist, aber probiers mal aus

lies die formel genauer, in E9 =WENN(Stempeln!$A9=A11;B11-Stempeln!$C9;0)
in E8 =WENN(Stempeln!$A8=A9;B9-Stempeln!$C8;0)

siehst du den unterschied?

gruß
robert


  

Betrifft: AW: bitte GENAU schauen.. von: André
Geschrieben am: 21.01.2010 12:11:57

Nochmal Hallo,

Du meinst also die Formeln in Deiner Tabelle, nicht in meiner!? Da stehen aber andere Formeln drin als die, die Du hier nennst.
Trotzdem verstehe ich nicht, worauf Du hinauswillst. In einer definierten Tabelle gibt es eine Spaltenformel, die immer dann eingesetzt wird, wenn eine neue Zeile angefügt wird. Wie soll das funktionieren, wenn ich in unterschiedlichen Zeilen unterschiedliche Formeln verwende?

Gruß, André


  

Betrifft: das sind DEINE formeln.. von: robert
Geschrieben am: 21.01.2010 12:35:58

in DEINER Datei........

in E9 =WENN(Stempeln!$A9=A11;B11-Stempeln!$C9;0)
probier mal

in E9 =WENN(Stempeln!$A9=A10;B10-Stempeln!$C9;0)

gruß
robert


  

Betrifft: AW: das sind DEINE formeln.. von: André
Geschrieben am: 21.01.2010 12:55:23

Hä? Wie das denn?
In der von mir hochgeladenen Tabelle steht in E8 die Formel:

=WENN(Stempeln[[#Diese Zeile];[Tag]]=A9;B9-Stempeln[[#Diese Zeile];[gehen]];0)

und in E9 steht:
=WENN(Stempeln[[#Diese Zeile];[Tag]]=A10;B10-Stempeln[[#Diese Zeile];[gehen]];0)

Kann es sein, daß Du die .XLSX in einer Excel Version kleiner 2007 öffnest?
Selbst wenn, dann stimmt die von Dir genannte Formel nicht mit der von mir erstellten überein; außer Du fügst eine Zeile zur Tabelle hinzu. Dann ergibt sich die von Dir genannte Formel. Und genau das ist ja das Problem, für welches ich eine Lösung suche.

Gruß, André


  

Betrifft: ..Ja, Excel2003! sorry.. von: robert
Geschrieben am: 21.01.2010 15:01:04

...komme jetzt auch nicht weiter, vielleicht hat einer mehr ahnung
bei eingabe mit LISTEN

gruß
robert


Beiträge aus den Excel-Beispielen zum Thema "Tabellenbereich - Verweis auf andere Zeilen"