Daten aus txt-Datei heraussuchen

Bild

Betrifft: Daten aus txt-Datei heraussuchen
von: Tom
Geschrieben am: 02.09.2015 14:30:40

Hallo Zusammen,
ich erhalte wöchentlich eine umfangreiche txt-Datei, die Unmengen an Daten enthält. Außerdem sind Leerzeilen mit Nullen aufgefüllt - alles sehr unübersichtlich!
An hand eines Kriteriums (besteht aus 4 Buchstaben WXYZ)lassen sich die relevanten Werte finden. Alle Zeichen danach (12345...), d.h. bis zum nächsten Leerzeichen bilden die BestellNr.
Alle 30 Zeichen vor dieser BestellNr., d.h. vor den 4 Buchstaben(WXYZ12345)bilden einen Namen.
in der Ergebnisdatei soll dann folgendes stehen:
Name Bestellnummer
Müller 12345...
Meier 23456...
.....
Schon mal ein großes Dankeschön!
TOM :-)

Bild

Betrifft: AW: Daten aus txt-Datei heraussuchen
von: Rudi Maintaire
Geschrieben am: 02.09.2015 14:41:08
Hallo,

ABC
1TextNameBstNr
2blabla001  
3Heinz Müller WXYZ12345 weiterer TextHeinz Müller12345
4blabla002  
5Werner Maier-Schulte WXYZ56789456 blablablaWerner Maier-Schulte56789456

ZelleFormel
B2=WENN(ISTZAHL(FINDEN("WXYZ";A2));LINKS(A2;FINDEN("WXYZ";A2)-1);"")
C2=WENN(B2<>"";LINKS(TEIL(A2;FINDEN("WXYZ";A2)+4;99);FINDEN(" ";TEIL(A2;FINDEN("WXYZ";A2)+4;99))-1);"")

Gruß
Rudi

Bild

Betrifft: AW: Daten aus txt-Datei heraussuchen
von: Tom
Geschrieben am: 02.09.2015 15:01:23
... oh, ohne Macro, super! Allerdings hab ich wohl vergessen zu erwähnen, dass auch vor dem Namen text steht.Also in deinem Bsp.:
weiterer Text Heinz Müller WXYZ12345 weiterer Text
Gruß TOM

Bild

Betrifft: AW: Daten aus txt-Datei heraussuchen
von: Rudi Maintaire
Geschrieben am: 02.09.2015 15:05:33
Zitat: Alle 30 Zeichen vor dieser BestellNr., d.h. vor den 4 Buchstaben(WXYZ12345)bilden einen Namen.
Und daran hab ich mich gehalten.

Bild

Betrifft: AW: Daten aus txt-Datei heraussuchen
von: Tom
Geschrieben am: 02.09.2015 15:13:24
klar, hab ja auch gesagt, dass ich was vergessen habe. ist wohl besser ich füge das nächste Mal eine Beispieldatei hinzu.
Die jetzige Formel schneidet nun aber leider den Test vor dem Namen nicht ab. Kannst du mir da nochmal bitte hefen?
Gruß Tom

Bild

Betrifft: den Test vor dem Namen
von: Rudi Maintaire
Geschrieben am: 02.09.2015 15:16:31
wie identifiziert man den?

Bild

Betrifft: AW: den Test vor dem Namen
von: Tom
Geschrieben am: 02.09.2015 15:23:15
... so sieht eine Zeile aus:
30000000012015070720150713122000202269539 SR9782000000000008550001900000000001625100000006000000000010175000000000000000000010175Schumann/Andy WXYZ9825993073 020300
hilft das?

Bild

Betrifft: AW: den Test vor dem Namen
von: Tom
Geschrieben am: 02.09.2015 15:25:31
hab das "!" vergessen!!

Bild

Betrifft: AW: den Test vor dem Namen
von: Rudi Maintaire
Geschrieben am: 02.09.2015 15:39:42
das Stück zwischen letzter Ziffer und WXYZ:
=WENN(ISTZAHL(FINDEN("WXYZ";A2));TEIL(LINKS(A2;FINDEN("WXYZ";A2)-1);VERWEIS(WAHR; ISTZAHL(TEIL(LINKS(A2;FINDEN("WXYZ";A2)-1);ZEILE($1:$200);1)*1);ZEILE($1:$200))+1;99);"")
Gruß
Rudi

Bild

Betrifft: AW: den Test vor dem Namen
von: Tom
Geschrieben am: 02.09.2015 15:49:45
PERFEKT! Vielen Dank!
TOM

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Ergebnisse sortieren"