Live-Forum - Die aktuellen Beiträge
Datum
Titel
19.07.2024 18:36:17
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Daten auslesen in Excel 2003

Daten auslesen in Excel 2003
20.11.2013 10:01:09
Hussain
Liebe Excel Community,
ich habe folgende Schwierigkeit in Excel:
Kunde Ortskürzel Bsp Ausgelesene Ortskürzel
Arnold MUC MUC, NY
Arnold NY
Daniel HK HK,MUC
Daniel MUC
Hans DD DD
Frank MUC MUC,NY, HK
Frank NY
Frank HK
Unter folgenden Link könnt ihr einen Excel-Screenshot sehen:
Userbild
Ich habe Kunden und die dazugehörgen Ortskürzel gegeben und möchte in der Spalte "Bsp Ausgelesene Ortskürzel" eine Formel hinterlegen, welche die Ortskürzel zusammenfasst und mit einem Komma trennt.
Für Arnold sollten dann in der ersten Zeile in der dritten Spalte "MUC, NY" stehen. In der zweiten Zeile sollte dann nichts mehr stehen. Die Funktion sollte demnach verstehen, dass die 3 Spalte mit einem neuen Kunden beginnt und dann die dazugheörigen Ortskürzel zusammensuchen und mit einem Komma getrennt darstellen.
Wie kann ich das in Excel lösen? (Nutze Excel 2003)
Ich hoffe, dass Ihr mein Problem versteht
Herzlichen Dank schonmal.
Beste Grüße
Bilal

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Daten auslesen in Excel 2003
20.11.2013 11:00:04
Rudi
Hallo,
Die Kürzel an der letzten Pos. ist einfacher.
Per Hilfsspalte, Liste nach Namen sortiert!
ABCDEF
1NameKürzelKürzel2  HS
2aqq, w  q
3aw   q, w
4bee, r, t  e
5br   e, r
6bt   e, r, t
7czz, u  z
8cu   z, u
9dii, o, p, a  i
10do   i, o
11dp   i, o, p
12da   i, o, p, a

ZelleFormel
C2=WENN(A2=A1;"";VERWEIS(2;1/($A$2:$A$12=A2);$F$2:$F$12))
C3=WENN(A3=A2;"";VERWEIS(2;1/($A$2:$A$12=A3);$F$2:$F$12))
C2=WENN(A2=A1;"";VERWEIS(2;1/($A$2:$A$12=A2);$F$2:$F$12))
C3=WENN(A3=A2;"";VERWEIS(2;1/($A$2:$A$12=A3);$F$2:$F$12))
C4=WENN(A4=A3;"";VERWEIS(2;1/($A$2:$A$12=A4);$F$2:$F$12))
F2=B2
F3=WENN(A3=A2;F2& ", " & B3;B3)
F4=WENN(A4=A3;F3& ", " & B4;B4)

Gruß
Rudi

Anzeige
@Rudi :geloest siehe MOF gruss owT
20.11.2013 11:17:13
hary
.

AW: Daten auslesen in Excel 2003
20.11.2013 13:33:11
KlausF
Hallo Bilal,
anbei eine Lösung mit benutzerdefinierter Funktion
https://www.herber.de/bbs/user/88167.xls
Wird der Datenbereich verschoben muss die Formel an 2 Stellen manuell angepasst werden:
=WENN(C4=C5;"";Verbinden(INDIREKT((ADRESSE(VERGLEICH(C4;C:C;0);1)) & ":C$" & (WENN(ZÄHLENWENN(C4:C$15;C4)=1;INDEX(ZEILE();VERGLEICH(C4;C4:C$15;0));0))); 4))
C ist die Kundenspalte
4 ist die Spalte der Ortskürzel (hier Spalte D)
Gruß
Klaus

307 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige