Formel optimieren



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Formel optimieren
von: Josi
Geschrieben am: 16.05.2002 - 14:52:52

Hallo zusammen ich hab hier eine Formel die funktioniert super!
Nur kann man das noch eleganter bzw. kürzer lösen? denn wenn ich sie erweitern müsste komm ich irgendwann an die grenze mit den Klammern

=WENN(A1="";0;WENN(A19="gewinnsätze 3";WENN(UND(V16=A1;A18="6er Paarkreuzsystem")=WAHR;27;WENN(UND(V16=A1;A18="werner scheffler system")=WAHR;24;WENN(UND(V16=A1;A18="4er bundessystem")=WAHR;18;WENN(UND(V16=A1;A18="jeder gegen jeden")=WAHR;15;WENN(UND(V16=A1;A18="modifizierter swaytling cup")=WAHR;12;(SUMME(AG21:AG36)))))));WENN(UND(V16=A1;A18="6er Paarkreuzsystem")=WAHR;36;WENN(UND(V16=A1;A18="werner scheffler system")=WAHR;32;WENN(UND(V16=A1;A18="4er bundessystem")=WAHR;24;WENN(UND(V16=A1;A18="jeder gegen jeden")=WAHR;20;WENN(UND(V16=A1;A18="modifizierter swaytling cup")=WAHR;16;(SUMME(AG21:AG36)))))))))

Im vorraus schon vielen Dank
Josi

nach oben   nach unten

Re: Formel optimieren
von: Volker Rupprecht
Geschrieben am: 16.05.2002 - 20:16:49

Hi Josi,

Du kannst die Formel "verkürzen" und auch variabel gestalten, indem Du die 'Wenn-Kriterien' [in deinem Fall in ""] nicht ausschreibst, sondern auf eine Zelle verweisen läßt, in der dieses Kriterium steht!
Beispiel:
"gewinnsätze 3" könnte in Zelle BA1 stehen - anstatt "gewinnsätze 3" würdest Du an dieser Stelle der Formel einfach BA1 eintragen. Die Formel wird kürzer und die Suchbegriffe könnten in einer Spalte untereinanderstehen.
Ob man die Formel auch anders kürzen kann sieht man wahrscheinlich nur, wenn man die Tabelle gesehen hat und Dein Ziel kennt. Solltest Du mir die Tabelle senden wollen, meine E-Mail Adresse ist mitangegeben!

Gruß,

Volker

nach oben   nach unten

Re: Formel optimieren
von: tw
Geschrieben am: 17.05.2002 - 13:45:29

Hallo Josi,

wenn du die überflüssigen WAHR-Abfragen löschst, wird die Formel schon mal was kleiner. Z.B.

WENN(UND(V16=A1;A18="werner scheffler system")=WAHR; ...

liefert das gleiche Ergebnis wie

WENN(UND(V16=A1;A18="werner scheffler system"); ...

Zwei Wahrheitsabfragen werden innerhalb der Klammern durch die Gleichheitszeichen erledigt. Die UND-Funktion bildet die dritte Wahrheitsabfrage. Wenn also die ersten zwei WAHR liefern, liefert UND automatisch WAHR.
Außerdem wird die Abfrage A1=V16 immer wieder gestartet und SUMME kann auch einmal rausgeholt werden. Vorschlag:

=WENN(A1="";0;WENN(A1=V16;WENN(A19="gewinnsätze 3";WENN(A18="6er Paarkreuzsystem";27;WENN(A18="werner scheffler system";24;WENN(A18="4er bundessystem";18;WENN(A18="jeder gegen jeden";15;WENN(A18="modifizierter swaytling cup";12;)))));WENN(A18="6er Paarkreuzsystem";36;WENN(A18="werner scheffler system";32;WENN(A18="4er bundessystem";24;WENN(A18="jeder gegen jeden";20;WENN(A18="modifizierter swaytling cup";16))))));SUMME(AG21:AG36)))

Gruß tw






 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Formel optimieren"