Runden (Formel)



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Runden (Formel)
von: Martin
Geschrieben am: 20.05.2002 - 10:41:33

Ich möchte in einer Spalte das Total einer Addition von vier Zellen automatisch kaufmännisch gerundet haben.
Wie lautet die gesamte Formel?
Danke!

nach oben   nach unten

Re: Runden (Formel)
von: Hans W. Herber
Geschrieben am: 20.05.2002 - 11:15:44

Hallo Martin,

wie folgt:
=RUNDEN(SUMME(A:A);2)

hans

nach oben   nach unten

Re: Runden (Formel)
von: Rolf, Lgh.
Geschrieben am: 20.05.2002 - 11:19:14

Hallo Martin,
=RUNDEN(Zellen;Anzahl_Stellen)
z. B.: =RUNDEN(B1:B4;2)
Gruss Rolf
nach oben   nach unten

Re: Runden (Formel)
von: Mike
Geschrieben am: 20.05.2002 - 11:25:04

Hallo Martin,

wenn du es kaufmännisch gerundet haben möchtest, nimm:
=RUNDEN(SUMME(A:A)*20;0)/20

Gruß Mike

nach oben   nach unten

Re: Runden (Formel)
von: Rolf, Lgh.
Geschrieben am: 20.05.2002 - 11:31:30

Hallo Mike,
warum *20/20? Die Excel-Funktion RUNDEN rundet bereits korrekt kaufmännisch (im Gegensatz der VBA-Funktion ROUND)!
Gruss Rolf

nach oben   nach unten

Re: Runden (Formel)
von: Mike
Geschrieben am: 20.05.2002 - 11:37:32

Hi Rolf,
hast natürlich recht. War gedanklich noch auf "'ner anderen Baustelle".

Gruß Mike


nach oben   nach unten

Korrektur
von: Rolf, Lgh.
Geschrieben am: 20.05.2002 - 12:11:30

=RUNDEN(SUMME(Zellen);Anzahl_Stellen)
z. B.: =RUNDEN(SUMME(B1:B4);2)
nach oben   nach unten

Re: Runden (Formel)-Nachtrag-
von: Mike
Geschrieben am: 20.05.2002 - 12:15:37

Hallo Rolf,
"kaufmännisch runden" habe ich so verstanden, dass die Nachkommazahl als solche gerundet wird und nicht nur die letzte Stelle.
Wenn du z.B. die Summe aus drei Mal der Zahl 2,01 bildest, gibt deine Formel den richtigen Wert 6,03 an. Kaufmännisch aber -so wie ich es weiß- möchte man den Wert 6,05 haben. Dies gelingt z.B. mit meiner vorgeschlagenen Formel. Aber vielleicht bin ich ja auch auf dem Holzweg?

Gruß Mike


nach oben   nach unten

Re: Runden (Formel)-Nachtrag-
von: Rolf, Lgh.
Geschrieben am: 20.05.2002 - 12:59:08

Wollen wir mal sehen, welche Lösung Martin sucht?!
;-)

MS Excel von Rolf, Lgh. an Mike
 ABCD
12,0132,0132,0132,013
22,0142,0142,0142,014
32,0152,0152,0152,015
42,0142,0142,0142,014
52,0192,0192,0192,019
610,0810,1010,0710,075
7=RUNDEN(SUMME(A1:A5);2)=RUNDEN(SUMME(B1:B5)*20;0)/20=SUMME(RUNDEN(C1;2);RUNDEN(C2;2);RUNDEN(C4;2);RUNDEN(C3;2);RUNDEN(C5;2))=SUMME(D1:D5)

Gruss Rolf
Rolf

nach oben   nach unten

Re: Runden (Formel)-Nachtrag-
von: Mike
Geschrieben am: 20.05.2002 - 13:19:41

Hallo Rolf,
schön dargestellt. Schade ist nur, dass der, für den dies gedacht ist, nichts mehr von sich hören lässt.

Gruß Mike


nach oben   nach unten

{=SUMME(RUNDEN(A5:A8;2))}
von: snickers
Geschrieben am: 20.05.2002 - 15:28:07

ARRAY-Formel: die geschweifte Klammer nicht eingeben sondern die Eingabe abschließen mit Strg+Umsch+Enter

bei meiner Lösung wird jede Zelle zuerst kaufmännisch gerundet, und daraus die Summe gebildet:

4x 3,142 = 12,56

bei =runden(Summe(...);2) ergibt 12,57

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Runden (Formel)"