Excel Summe aus anderer Zeile

Bild

Betrifft: Excel Summe aus anderer Zeile
von: Marc
Geschrieben am: 16.07.2015 11:36:34

Hallo Zusammen,
ich habe eine Problem, ich muss aus einer Excel Tabelle Summen aufgrund von Text auslesen. Dies ist ja eigentlich mit der Summewenn-Formel kein Problem.
Zusätzlich stellt sich die Problematik, dass zum Teil der Text, nicht auf der gleichen höhe wie die Zahl ist (eine Zeile unten).
[table="width: 500, class: grid, align: left"]
[tr]
[td]Text1[/td]
[td]300[/td]
[/tr]
[tr]
[td]Text2[/td]
[td][/td]
[/tr]
[tr]
[td]Text3[/td]
[td]350[/td]
[/tr]
[tr]
[td]Text4[/td]
[td][/td]
[/tr]
[/table]
Gibt es eine Formel, dass wenn ich nach Text2 suche mir auch den Wert 300 ausgegeben wird bzw. bei Text4 350?
http://www.pctipp.ch/forum/showthread.php?35803-Excel-Summer-aus-anderer-Zeile
Danke & Gruss

Bild

Betrifft: mit SUMMEWENN() ...
von: der neopa C
Geschrieben am: 16.07.2015 11:41:58
Hallo Mark,
... Du meinst oben nicht unten !?
Einfach so: =SUMMEWENN(A2:A5;"Text2";B1:B4)
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit SUMMEWENN() ...
von: Marc
Geschrieben am: 16.07.2015 11:45:46
Ich meine oben,
der Wert bei den es mir bei Text2 ausgeben müsste wäre auch 300..
mit der summe wenn gibt er mir lediglich der wert auf der selben höhe an..

Bild

Betrifft: SUMMEWENN() geht schon ...
von: der neopa C
Geschrieben am: 16.07.2015 11:53:16
Hallo Marc,
... du musst nur den Auswertungsbereich in der Formel entsprechend versetzt anordnen. Dazu sieh meine Beispielformel im vorherigen Beitrag.
Anders wird es wenn die Werte "flatternd" in unterschiedlichen Zeilenabstand liegen. Aber das ist ja nicht der Fall. Oder?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: SUMMEWENN() geht schon ...
von: Marc
Geschrieben am: 16.07.2015 12:04:17
Hallo Werner,
erstmals Danke, dass Du Dir Zeit für mein Anliegen nimmst.
Leider funktioniert das nicht so einfach. Ich schildere kurz mein Problem ein bisschen ausführlicher.
Ich habe ein Liste wo es immer zwei Zeilen hat mit Einem Kreditor und einem Buchungstext. In der oberen Zeile (neben Kreditor) ist der Wert ausgegeben.
Mein Ziel wäre, dass ich die ganze Tabelle nach einem Namen durchsuchen kann (=SUMMEWENN(B7:B48;"*Meier*";G7:G48) und er mir dann auch der Wert ausgeben würde, wenn der Name erst auf der zweiten Zeile gefunden wäre.
Userbild

Bild

Betrifft: warum versetzt Du den Auswertungsbereich nicht?...
von: der neopa C
Geschrieben am: 16.07.2015 12:12:09
Hallo Marc,
... außerdem anstelle einer Bilddatei ist es fast immer günstiger gleich die entsprechende Excelarbeitsmappe hier hoch zu laden.
Also die Formel hier ungetestet: (=SUMMEWENN(B7:B48;"*Meier*";G6:G47)
Gruß Werner
.. , - ...


Bild

Betrifft: AW: warum versetzt Du den Auswertungsbereich nicht?...
von: Marc
Geschrieben am: 16.07.2015 12:19:15
Ich kann den Auswertungsbereich nicht versetzten, weill zum Teil der gesuchte Name auch in der ersten Zeile befindet. (Bsp. Visa)
Wäre nun in der Liste weiter unten der Name Meier in der ersten Zeile, würde es mir den Wert nicht ausgeben.
Deshalb müsste die Formel ein wenig dynamischer sein.

Bild

Betrifft: auch dann SUMMEWENN(), jedenfalls ...
von: der neopa C
Geschrieben am: 16.07.2015 12:37:04
Hallo Marc,
... wenn ich mir Dein eingestelltes Bild so betrachte.
Du hast ja nur in jeder zweiten Zeile einen zugeordneten Wert.
Oder doch anders? Dann aber bitte mit einem relevanten Auszug aus der Excelarbeitsamppe.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: auch dann SUMMEWENN(), jedenfalls ...
von: Marc
Geschrieben am: 16.07.2015 12:51:58
Hallo Werner,
ich habe jetzt mal die Arbeitsmappe mit dem Beispiel hochgeladen.
https://www.herber.de/bbs/user/98855.xlsm
Mit der jetztigen Formel sucht er mir alle Werte die mit Bucher in der ersten Zeile sind.
Sobald aber der Text in der unteren Zeile ist (wie. zbsp. bei Hertz), gibt er mir den Wert nicht mehr aus. Ich bräuchte aber alle Werte.
Kann ich das überhaubt verformeln?
Gruss
Marc

Bild

Betrifft: AW: auch dann SUMMEWENN(), jedenfalls ...
von: Andre
Geschrieben am: 16.07.2015 13:00:52
Hallo Marc,
Probiers mal so: =SUMMEWENN(B7:B16;"*Bucher*";G7:G16)+SUMMEWENN(B7:B16;"*Bucher*";G6:G15)
Gruß
Andre

Bild

Betrifft: AW: auch dann SUMMEWENN(), jedenfalls ...
von: Marc
Geschrieben am: 16.07.2015 13:08:44
Danke Andre, so passt es.
Gruss
Marc

Bild

Betrifft: ok, jetzt weiß ich auch was Du gemeint hast owT
von: der neopa C
Geschrieben am: 16.07.2015 13:14:27
Gruß Werner
.. , - ...

Bild

Betrifft: was kann ich jetzt noch schreiben ....
von: der neopa C
Geschrieben am: 16.07.2015 13:10:58
Hallo Marc,
... dann schreibe doch einfach mal die Formel wie ich sie Dir nun schon mehrfach angegeben habe.
Sieh mal:

 ABCDEFGHI
4        Kosten Bucher
5        999,99
6         
701.10.2014411029/74/HERTZ GMBH 2421.1001K 251,16  
8 SE AK580, Mietwagen Bucher   8260   
901.10.201453760/52720/VISA ADORJAN 2421.1050K 158,39  
10 Visa v. 28.09.14/ Mietwagen   310   
1101.10.201453777/50830/VISA LEISI 2421.1050K 218,84  
12 Visa v. 28.09.14/ Mietwagen   8200   
1301.10.201453791/52530/VISA Bucher 2421.1050K 2.678,13  
14 Visa v. 28.09.14/ Mietwagen   8200   
1501.10.201453796/52640/VISA STUDER 2421.1050K 233,56  
16 Visa v. 28.09.14/ Mietwagen   8200   
1711.10.2014611029/74/HERTZ GMBH 2421.1001K 748,83  
18 SE AK580, Mietwagen Bucher   8260   
19         

Formeln der Tabelle
ZelleFormel
I5=SUMMEWENN(B7:B99;"*Bucher*";G6:G18)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Excel Summe aus anderer Zeile"