Ree an atikar ----- Inhalt einer Spalte auf zwei

Bild

Betrifft: Ree an atikar ----- Inhalt einer Spalte auf zwei
von: Frank
Geschrieben am: 11.12.2003 10:53:56

Hallo,
danke für die schnelle Hilfe, die auch funktioniert.
Nur habe ich noch zwei Probleme.
1.Das Minuszeichen soll mit als erstes Zeichen in der 2. Spalte erscheinen.
Also so:

Spalte1: =000BR_001
Spalte2: -W1BA1

Und dann bräuchte ich bitte noch hilfe, wie ich es machen muss, dass das nur dann zerlegt wird wenn wie bei mit in A3 ein inhalt vorhanden ist, also leere Zellen (z.B. A6 oder so)nicht berücksichtigt werden. Denn so steht in Zellen wo in A kein Inhalt ist immer #Wert.

Danke schon mal

Frank

Bild


Betrifft: AW: Ree an atikar ----- Inhalt einer Spalte auf zwei
von: Mac4
Geschrieben am: 11.12.2003 11:05:54

Hi Frank,

ich misch mich mal ein:

Spalte 1 =WENN(ISTFEHLER(LINKS(A1;FINDEN("-";A1;1)-1));"";LINKS(A1;FINDEN("-";A1;1)-1))
Hier ist auch schon das Problem mit dem Fehlerwert erledigt.
Die zweite Formel sieht dann entsprechend aus:
Spalte 2 =WENN(ISTFEHLER(RECHTS(A1;LÄNGE(A1)-FINDEN("-";A1;1)+1));"";RECHTS(A1;LÄNGE(A1)-FINDEN("-";A1;1)+1))

Marc


Bild

Beiträge aus den Excel-Beispielen zum Thema " Ree an atikar ----- Inhalt einer Spalte auf zwei "