Microsoft Excel

Herbers Excel/VBA-Archiv

Excel - Differenzen | Herbers Excel-Forum


Betrifft: Excel - Differenzen von: Sven Durst
Geschrieben am: 02.09.2008 07:49:38

Hallo liebes Forum,

ich habe ein Problem. Ich muß in Excel eine Tabelle zur Provisionierung erstellen, die nach gestaffelten Provisionen rechnet:

von 0 bis 100 EUR gibt es EUR 30,00
von 100 bis 200 EUR gibt es für die Differenz des 100 EUR übersteigenden Betrages zusätzlich 25 %,
von 200 bis 300 EUR gibt es für die Differenz des 200 EUR übersteigenden Betrages zusätzlich 20 %
von 300 bis 500 EUR gibt es für die Differenz des 300 EUR übersteigenden Betrages zusätzlich 15 %
von 500 bis 1000 EUR gibt es für die Differenz des 500 EUR übersteigenden Betrages zusätzlich 10 %
ab 1000,01 EUR gibt es für die 1000 EUR übersteigenden Beträge zusätzlich 5 %.

D.H. wenn ich einen Vertrag mit 350 EUR abschließe bekomme ich die ersten 100 EUR 30 EUR (Stufe1),
für die zweiten 100 EUR zusätzlich 25 %, für die dritten 100 EUR zusätzlich 20 % und für die restlichen 50 EUR zusätzlich 15 %.

Wie kann ich das in einer Formel realisieren?

Bitte um Eure Hilfe.

Vielen Dank schon im Voraus.

Sven

  

Betrifft: AW: Excel - Differenzen von: David
Geschrieben am: 02.09.2008 08:50:19

Hallo Sven,

Wenn dein Wert in A1 steht, folgende Formel:

=SUMME(30;MAX(MIN($A$1-100;200-100);0)*25%;MAX(MIN($A$1-200;300-200);0)*20%;MAX(MIN($A$1-300;500-300) ;0)*15%;MAX(MIN($A$1-500;1000-500);0)*10%;MAX(MIN($A$1-1000;9999999-1000);0)*5%)

Der Teil, wie z. Bsp.

MAX(MIN($A$1-100;200-100);0)*25%

muss für andere Intervalle ggf. angepasst werden. Die 100 ist die Untergrenze des Intervalls, die 200 die Obergrenze, %-Wert ist klar. Das Max(...;0) ist notwendig, damit keine Minus-Werte verwendet werden.
Ich bin mal davon ausgegangen, dass keine Beträge ab 10 Mio. vorkommen. ;-)

Rückmeldung wäre nett.

Gruß

David


  

Betrifft: AW: Excel - Differenzen von: Sven Durst
Geschrieben am: 02.09.2008 09:02:10

Hallo David,

vielen vielen Dank für Deine schnelle Hilfe.....werde Deine Formel nachher gleich testen.

Melde mich dann nochmals.

Gruß
Sven


  

Betrifft: AW: Excel - Differenzen von: Tobias
Geschrieben am: 02.09.2008 11:00:26

Hallo Sven!
Ich denke mal, dass David das Problem bereits gelöst hat. Ansonsten hätte ich noch diesen Link im Angebot:
https://www.herber.de/forum/archiv/1004to1008/t1005727.htm

Es ging prinzipiell um ein ähnliches Problem.

Gruß, Tobi
http://www.vba-blog.de/


Beiträge aus den Excel-Beispielen zum Thema "Excel - Differenzen"