Microsoft Excel

Herbers Excel/VBA-Archiv

Frage zu =VLOOKUP | Herbers Excel-Forum


Betrifft: Frage zu =VLOOKUP von: ray
Geschrieben am: 05.01.2010 10:25:27

Hallo und allen eine frohes neues Jahr,

in vbacode benutze ich sverweis:
=VLOOKUP(RC[-1],liste!RC[-1]:R[617]C[23],3,FALSE)

jetzt möchte ich:
Suche "77" im Bereich von e:\data\mängelliste.xls(Mappe 'meldungen')
und gebe wieder, in welcher Zeile "77" gefunden wurde.

Kann mir jemand helfen?

Viele Grüße aus leicht verschneiten Hamburg

Ray

  

Betrifft: AW: Frage zu =VLOOKUP von: Ramses
Geschrieben am: 05.01.2010 10:38:39

Hallo

Dazu eignet sich VLOOKUP nicht, verwende stattdessen MATCH bzw. VERGLEICH.
Die Anweisung für die Formel kannst du auch mit dem Makrorekorder aufzeichnen

Gruss Rainer


  

Betrifft: AW: Frage zu =VLOOKUP von: ray
Geschrieben am: 05.01.2010 10:43:26

Hallo und danke.

Ich habe das mal eben probiert, aber das ist ja nur wie zählen. Was ich brauche ist ja, die Zeile in der 77 gefunden wurde.

Hat jemand noch ne Idee?

Gruß Ray


  

Betrifft: AW: Frage zu =VLOOKUP von: Ramses
Geschrieben am: 05.01.2010 10:47:54

Hallo

"...aber das ist ja nur wie zählen..."

Na und,... wichtig ist doch, dass du dein korrektes Ergebnis bekommst.

Tabelle1

 ABCD
1Gesucht77 1
2Gefunden in Zeile8 4
3   5
4   34
5   86
6   99
7   34
8   77
9   34
10   61

Formeln der Tabelle
ZelleFormel
B2=VERGLEICH(B1;D1:D10;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruss Rainer


  

Betrifft: Fast geschafft... von: ray
Geschrieben am: 05.01.2010 11:52:51

Hi Rainer,
ich habe das grad mal probiert:
=VERGLEICH(A1;[mängelliste.xls]meldungen!$C$2:$H$10;0)
A1 = 312
ich bekomme aber immer ein NV#
Wenn ich aber in der Bearbeitungsleiste auf fx klicke zeigt mir das Fenster unter Suchmatrix an, dass 312 vorhanden ist.
Bei Formelergebnis steht aber dann nix.

Was mach ich denn jetzt noch falsch?

Gruß Ray


  

Betrifft: Rames ist ein großer! von: ray
Geschrieben am: 05.01.2010 12:01:15

Die Lösung:
=VERGLEICH(A1;[mängelliste.xls]meldungen!C:C;0)

Vielen Dank für den Input Ramses.

Gruß Ray