Herbers Excel-Forum - das Archiv

VLOOKUP

Bild

Betrifft: VLOOKUP
von: Guy

Geschrieben am: 17.12.2006 23:39:27
Hallo, Ich bitte um eure Hilfe bei dem folgendem Problem. Bitte auf den nachfolgenden Link klicken :
https://www.herber.de/bbs/user/39078.xls
Die gewünschten Ergebnisse sind angegeben, aber ich weiss nicht, wie man diese per Formel dort einbringen kann. Als Hilfe dient die 3-fache IF-Schleife, die hoffentlich verständlich ist.
Danke. Guy.
Bild

Betrifft: AW: VLOOKUP
von: ingUR

Geschrieben am: 18.12.2006 00:09:09
Hallo, @Guy,
eine Lösungsmöglichkeit:
TABELLE

 ABCDE
3KONTO EURUSDCDN
4     
5     
6777 400100200
7888 204030

Formeln der Tabelle
ZelleFormel
C6=SUMMENPRODUKT((DATA!$B$5:$B$12<>"Y")*1;(DATA!$C$5:$C$12=TABELLE!C$3)*1;(DATA!$A$5:$A$12=TABELLE!$A6)*1;(DATA!$D$5:$D$12))
D6=SUMMENPRODUKT((DATA!$B$5:$B$12<>"Y")*1;(DATA!$C$5:$C$12=TABELLE!D$3)*1;(DATA!$A$5:$A$12=TABELLE!$A6)*1;(DATA!$D$5:$D$12))
E6=SUMMENPRODUKT((DATA!$B$5:$B$12<>"Y")*1;(DATA!$C$5:$C$12=TABELLE!E$3)*1;(DATA!$A$5:$A$12=TABELLE!$A6)*1;(DATA!$D$5:$D$12))
C7=SUMMENPRODUKT((DATA!$B$5:$B$12<>"Y")*1;(DATA!$C$5:$C$12=TABELLE!C$3)*1;(DATA!$A$5:$A$12=TABELLE!$A7)*1;(DATA!$D$5:$D$12))
D7=SUMMENPRODUKT((DATA!$B$5:$B$12<>"Y")*1;(DATA!$C$5:$C$12=TABELLE!D$3)*1;(DATA!$A$5:$A$12=TABELLE!$A7)*1;(DATA!$D$5:$D$12))
E7=SUMMENPRODUKT((DATA!$B$5:$B$12<>"Y")*1;(DATA!$C$5:$C$12=TABELLE!E$3)*1;(DATA!$A$5:$A$12=TABELLE!$A7)*1;(DATA!$D$5:$D$12))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Bereiche sind ggf. anzupassen.
Gruß,
Uwe
Bild

Betrifft: AW: LOOKUP
von: Erich G.

Geschrieben am: 18.12.2006 00:09:19
Hallo Guy,
meinst du so?
 ABCDE
6777 400100200
7888 204030

Formeln der Tabelle
ZelleFormel
C6=VERWEIS(2;1/(DATA!$A$5:$A$12&DATA!$B$5:$B$12&DATA!$C$5:$C$12=$A6&"N"&C$3);DATA!$D$5:$D$12)
D6=VERWEIS(2;1/(DATA!$A$5:$A$12&DATA!$B$5:$B$12&DATA!$C$5:$C$12=$A6&"N"&D$3);DATA!$D$5:$D$12)
C7=VERWEIS(2;1/(DATA!$A$5:$A$12&DATA!$B$5:$B$12&DATA!$C$5:$C$12=$A7&"N"&C$3);DATA!$D$5:$D$12)

Übersetzt:
LOOKUP(2,1/(DATA!$A$5:$A$12&DATA!$B$5:$B$12&DATA!$C$5:$C$12=$A6&"N"&C$3),DATA!$D$5:$D$12)
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
 Bild