Microsoft Excel

Herbers Excel/VBA-Archiv

Suche Trick für VLOOKUP

Thema: Suche Trick für VLOOKUP
Excel-Version: 10.0 (Office XP)

Betrifft: Suche Trick für VLOOKUP
von: Michael
Geschrieben am: 20.02.2003 - 17:38:26

Hallo Zusammen,
Gibt es einen Trick um mit dem VLOOKUP - Befehl auf eine Spalte zuzugreifen, die vor der Spalte mit dem vergleichenden Element ist ?
Ich habe folgende Formel die so funktioniert. Nur steht der Text in Wirklichkeit 11 Spalten vor dem Wert der gefunden werden soll.

Worksheets("vorlage").Cells(I, 34).FormulaR1C1 = "=VLOOKUP(MIN(R[0]C[-14]:R[" & z & "]C[-14]), R[0]C[-25]:R[" & z & "]C[-14],-11,0)" 'supplier of best offer

Mit der -11 habe ich jetzt meine Probleme.

Vorab Danke!

Michael

  

Re: Suche Trick für VLOOKUP
von: Panicman
Geschrieben am: 20.02.2003 - 17:49:52

Hallo Michael,

das geht mit Vlookup (Sverweis) nicht.
Statt dessen muß du die Funktionen Index() mit Match() (Vergleich) kombinieren.

Gruß
Holger

  

Re: Suche Trick für VLOOKUP
von: Michael
Geschrieben am: 20.02.2003 - 17:55:19

Hi Holger,
hast Du ein einfaches Beispiel,
damit ich das Prinzip verstehe und meine Formel entsprechend anpassen kann ?

Waere super

michael

  

Re: Suche Trick für VLOOKUP
von: Panicman
Geschrieben am: 20.02.2003 - 18:15:25

Hallo Michael,

mal als Formeln in einer Tabelle:

MS Excel von Panicman an Michael
 ABCDEFG
1A1N14SucheZin SpalteC
2B2O15  Spalte226
3C3P16  Spalte-113
4D4Q17  Spalte-2M
5E5R18   
6F6S19   
7G7T20   
8H8U21   
9I9V22   
10J10W23   
11K11X24   
12L12Y25   
13M13Z26   

Formeln:
G2 =SVERWEIS(F1;C1:D13;2;0)
G3 =Index(A1:D13;VERGLEICH(F1;C1:C13;0);2)
G4 =Index(A1:D13;VERGLEICH(F1;C1:C13;0);1)

Wenn du jetzt die VBA-Übersetztung braucht, mache den Makro-Rekorder an, gehe mit F2 in die Zelle, makieren, kopieren und in eine andere Zelle einfügen.

Gruß
Holger

  

Danke!
von: Michael
Geschrieben am: 20.02.2003 - 19:10:18

Hi Holger,
das sieht sehr gut aus,
ich denke nach einigem Grübeln werde ich es hingriegen.
Danke

michael